summaryrefslogtreecommitdiffstats
path: root/target/linux/orion/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-06-16 12:38:55 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-06-16 12:38:55 +0000
commite147bf8fa3c6e9023fbda64bfeb95de2910ab656 (patch)
tree4f56a36252d9ade2b8af8c853896d49c2f0afb3b /target/linux/orion/image
parent79bd4016bc091f29a6f53cd43c42c42897cfc78f (diff)
downloadmaster-31e0f0ae-e147bf8fa3c6e9023fbda64bfeb95de2910ab656.tar.gz
master-31e0f0ae-e147bf8fa3c6e9023fbda64bfeb95de2910ab656.tar.bz2
master-31e0f0ae-e147bf8fa3c6e9023fbda64bfeb95de2910ab656.zip
fixup machid workaround, generate uImage manually
SVN-Revision: 11497
Diffstat (limited to 'target/linux/orion/image')
-rw-r--r--target/linux/orion/image/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/target/linux/orion/image/Makefile b/target/linux/orion/image/Makefile
index 073317fecd..a8c2fbafff 100644
--- a/target/linux/orion/image/Makefile
+++ b/target/linux/orion/image/Makefile
@@ -11,11 +11,14 @@ define Image/Prepare
#
# XXX - FIXME, we hardcode for the WRT350N v2 for now
#
- echo -en "\x61\x70\xa0\xe3\x06\x7c\x87\xe3" > $(KDIR)/uImage
- cat $(LINUX_DIR)/arch/arm/boot/uImage >> $(KDIR)/uImage
+ echo -en "\x61\x70\xa0\xe3\x06\x7c\x87\xe3" > $(KDIR)/zImage
+ cat $(LINUX_DIR)/arch/arm/boot/zImage >> $(KDIR)/zImage
endef
define Image/BuildKernel
+ $(STAGING_DIR_HOST)/bin/mkimage -A arm -O linux -T kernel \
+ -C none -a 0x00008000 -e 0x00008000 -n 'Linux-$(LINUX_VERSION)' \
+ -d $(KDIR)/zImage $(KDIR)/uImage
cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
endef