summaryrefslogtreecommitdiffstats
path: root/target/linux/orion/image
diff options
context:
space:
mode:
authorTravis Kemen <thepeople@openwrt.org>2010-02-12 01:40:57 +0000
committerTravis Kemen <thepeople@openwrt.org>2010-02-12 01:40:57 +0000
commitcb9c37af385c64ee07c14f6b4e634d2d4cc4ad5c (patch)
tree92ebf07ebd466001ca3f3a1c6316537868a10bf0 /target/linux/orion/image
parent9e5844fda2400b5668188baf0ae3b7a68bb176b5 (diff)
downloadmaster-31e0f0ae-cb9c37af385c64ee07c14f6b4e634d2d4cc4ad5c.tar.gz
master-31e0f0ae-cb9c37af385c64ee07c14f6b4e634d2d4cc4ad5c.tar.bz2
master-31e0f0ae-cb9c37af385c64ee07c14f6b4e634d2d4cc4ad5c.zip
Update to v2.1 Stays closer to the stock firmware by using wrt350n.bin for the created image. Adds the possibility to create the image in two separate steps (-b / -z). Makefiles now support the possibility to include a u-boot image for a 100%-stock-like image.
Signed off by: Matthias Buecher <mail@maddes.net> SVN-Revision: 19596
Diffstat (limited to 'target/linux/orion/image')
-rw-r--r--target/linux/orion/image/Makefile18
1 files changed, 12 insertions, 6 deletions
diff --git a/target/linux/orion/image/Makefile b/target/linux/orion/image/Makefile
index c6c790ffbe..9577cd9a97 100644
--- a/target/linux/orion/image/Makefile
+++ b/target/linux/orion/image/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2008-2009 OpenWrt.org
+# Copyright (C) 2008-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -61,14 +61,18 @@ define Image/Build/Linksys
# create parameter file
echo ":kernel $5 ${BIN_DIR}/openwrt-$2-uImage" >"${TMP_DIR}/$2_webupgrade/$2.par"
echo ":rootfs 0 ${KDIR}/root.$1" >>"${TMP_DIR}/$2_webupgrade/$2.par"
-# create webupgrade image
+ [ ! -f "$(STAGING_DIR_HOST)/share/wrt350nv2-builder/u-boot.bin" ] || ( \
+ echo ":u-boot 0 $(STAGING_DIR_HOST)/share/wrt350nv2-builder/u-boot.bin" >>"${TMP_DIR}/$2_webupgrade/$2.par"; )
+# create bin file for recovery and webupgrade image
( cd "${TMP_DIR}/$2_webupgrade"; \
"${STAGING_DIR_HOST}/bin/$2-builder" \
- -v "${TMP_DIR}/$2_webupgrade/$2.par" \
- "${BIN_DIR}/openwrt-$2-$1-webupgrade.img"; \
+ -v -b "${TMP_DIR}/$2_webupgrade/$2.par"; \
)
# copy bin file as recovery image
- $(CP) "${TMP_DIR}/$2_webupgrade/openwrt-$2-$1-webupgrade.bin" "$(BIN_DIR)/openwrt-$2-$1-recovery.bin"
+ $(CP) "${TMP_DIR}/$2_webupgrade/wrt350n.bin" "$(BIN_DIR)/openwrt-$2-$1-recovery.bin"
+# create webupgrade image for stock firmware update mechanism
+ zip "${TMP_DIR}/$2_webupgrade/wrt350n.zip" "${TMP_DIR}/$2_webupgrade/wrt350n.bin"
+ "${STAGING_DIR_HOST}/bin/$2-builder" -v -z "${TMP_DIR}/$2_webupgrade/wrt350n.zip" "${BIN_DIR}/openwrt-$2-$1-webupgrade.img"
rm -rf "${TMP_DIR}/$2_webupgrade"
endef
@@ -85,8 +89,10 @@ endef
define Image/Build
$(call Image/Build/$(1),$(1))
$(call Image/Build/Netgear,$(1),wnr854t,NG_WNR854T,$(1))
- $(call Image/Build/Linksys,$(1),wrt350nv2,WNR350Nv2,$(1),1048576) # 5th parameter is kernel mtd size 0x00100000 = 1048576 / 0x001A0000 = 1703936
$(call Image/Build/Freecom,$(1),dt2,DT,$(1))
+# Leave WRT350Nv2 at last position due to webimage dependency for zip
+# 5th parameter is kernel mtd size, e.g. 0x00100000 = 1048576 or 0x001A0000 = 1703936
+ $(call Image/Build/Linksys,$(1),wrt350nv2,WNR350Nv2,$(1),1048576)
endef
define Image/Build/squashfs