summaryrefslogtreecommitdiffstats
path: root/target/linux/orion/image
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-04-04 15:53:55 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-04-04 15:53:55 +0000
commitb47fc0f936c0a49c4dc88621d3f48a62c82fb98a (patch)
tree87b04ae84b14f22b3eae5375d597e5aa79af9375 /target/linux/orion/image
parent90e89bf4a9161a157b880f6b5f562b6568f28ee3 (diff)
downloadmaster-31e0f0ae-b47fc0f936c0a49c4dc88621d3f48a62c82fb98a.tar.gz
master-31e0f0ae-b47fc0f936c0a49c4dc88621d3f48a62c82fb98a.tar.bz2
master-31e0f0ae-b47fc0f936c0a49c4dc88621d3f48a62c82fb98a.zip
add support for D-Link DNS-323
this patch adds support for D-Link DNS323 storage device. You can find more info here: http://dns323.lukaperkov.net/ Currently you need serial cable to flash OpenWrt on DNS-323. Signed-off-by: Luka Perkov < openwrt ->-to->- lukaperkov.net > SVN-Revision: 31198
Diffstat (limited to 'target/linux/orion/image')
-rw-r--r--target/linux/orion/image/dns323.mk36
1 files changed, 36 insertions, 0 deletions
diff --git a/target/linux/orion/image/dns323.mk b/target/linux/orion/image/dns323.mk
new file mode 100644
index 0000000000..c33e612956
--- /dev/null
+++ b/target/linux/orion/image/dns323.mk
@@ -0,0 +1,36 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Image/Prepare
+ cp $(LINUX_DIR)/arch/arm/boot/uImage $(KDIR)/uImage
+endef
+
+define Image/BuildKernel
+ # Orion Kernel uImages
+ # DNS-323: mach id 1542 (0x606)
+ echo -en "\x06\x1c\xa0\xe3\x06\x10\x81\xe3" > $(KDIR)/dns323-zImage
+ cat $(LINUX_DIR)/arch/arm/boot/zImage >> $(KDIR)/dns323-zImage
+ $(STAGING_DIR_HOST)/bin/mkimage -A arm -O linux -T kernel \
+ -C none -a 0x00008000 -e 0x00008000 -n 'Linux-$(LINUX_VERSION)' \
+ -d $(KDIR)/dns323-zImage $(KDIR)/dns323-uImage
+ cp $(KDIR)/dns323-uImage $(BIN_DIR)/openwrt-dns323-uImage
+endef
+
+define Image/Build/D-Link
+ # Orion DNS-323 Images
+ # mtd image
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-dns323-rootfs bs=128k
+endef
+
+define Image/Build
+$(call Image/Build/$(1),$(1))
+$(call Image/Build/D-Link,$(1),dns323,DNS-323,$(1))
+endef
+
+define Image/Build/squashfs
+$(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+endef