summaryrefslogtreecommitdiffstats
path: root/target/linux/orion/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-06-13 12:58:28 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-06-13 12:58:28 +0000
commit983b22aa95eed2fedc109d505105d1a46e8bdfa0 (patch)
tree3853c16d936eee33ea15e2871189b553078edba8 /target/linux/orion/image
parent957626ff7258baf1e28a5a484780c79bbf0450da (diff)
downloadmaster-31e0f0ae-983b22aa95eed2fedc109d505105d1a46e8bdfa0.tar.gz
master-31e0f0ae-983b22aa95eed2fedc109d505105d1a46e8bdfa0.tar.bz2
master-31e0f0ae-983b22aa95eed2fedc109d505105d1a46e8bdfa0.zip
temporary hack to fixup the mach id for the wrt350nv2
SVN-Revision: 11459
Diffstat (limited to 'target/linux/orion/image')
-rw-r--r--target/linux/orion/image/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/target/linux/orion/image/Makefile b/target/linux/orion/image/Makefile
index 073c24f63e..073317fecd 100644
--- a/target/linux/orion/image/Makefile
+++ b/target/linux/orion/image/Makefile
@@ -8,15 +8,15 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
define Image/Prepare
- cp $(LINUX_DIR)/arch/arm/boot/uImage $(KDIR)/uImage
+#
+# XXX - FIXME, we hardcode for the WRT350N v2 for now
+#
+ echo -en "\x61\x70\xa0\xe3\x06\x7c\x87\xe3" > $(KDIR)/uImage
+ cat $(LINUX_DIR)/arch/arm/boot/uImage >> $(KDIR)/uImage
endef
define Image/BuildKernel
cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
-#
-# XXX - FIXME
-#
-# BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/arm-magic.sh
endef
define Image/Build
@@ -26,7 +26,7 @@ endef
define Image/Build/squashfs
$(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
( \
- dd if=$(LINUX_DIR)/arch/arm/boot/uImage bs=1024k conv=sync; \
+ dd if=$(KDIR)/uImage bs=1024k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
) > $(BIN_DIR)/openwrt-$(BOARD)-$(1).img
endef