summaryrefslogtreecommitdiffstats
path: root/target/linux/orion/image
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-01-17 13:50:10 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-01-17 13:50:10 +0000
commit82e1ed603fd7fafd2acde1f53ba5eadff61eef4e (patch)
treeb609870d4f12b805a6811f8642d47dc79b60c466 /target/linux/orion/image
parent6f78b03bcb57124738def2e38fdd3e87bd8b5119 (diff)
downloadmaster-31e0f0ae-82e1ed603fd7fafd2acde1f53ba5eadff61eef4e.tar.gz
master-31e0f0ae-82e1ed603fd7fafd2acde1f53ba5eadff61eef4e.tar.bz2
master-31e0f0ae-82e1ed603fd7fafd2acde1f53ba5eadff61eef4e.zip
missing prerequisite for Orion images Webupgrade image building for WRT350Nv2 needs zip package. Copy command for WRT350Nv2 recovery image overrides error code of webupgrade builder, moved behind brackets. Removed indention of comments to avoid output in log. Signed-off by: Matthias Buecher <mail@maddes.net>
SVN-Revision: 19183
Diffstat (limited to 'target/linux/orion/image')
-rw-r--r--target/linux/orion/image/Makefile19
1 files changed, 13 insertions, 6 deletions
diff --git a/target/linux/orion/image/Makefile b/target/linux/orion/image/Makefile
index 338af419df..c6c790ffbe 100644
--- a/target/linux/orion/image/Makefile
+++ b/target/linux/orion/image/Makefile
@@ -49,24 +49,26 @@ define Image/Build/Netgear
endef
define Image/Build/Linksys
- # WRT350N v2 sysupgrade image
+# WRT350N v2 images
+# sysupgrade image
( \
dd if="${KDIR}/$2-uImage" bs=$5 conv=sync; \
dd if="${KDIR}/root.$1" bs=64k conv=sync; \
) > "${BIN_DIR}/openwrt-$2-$1.img"
- # WRT350N v2 webupgrade image for stock firmware
+# recovery image and webupgrade image for stock firmware
rm -rf "${TMP_DIR}/$2_webupgrade"
mkdir "${TMP_DIR}/$2_webupgrade"
- # create parameter file
+# create parameter file
echo ":kernel $5 ${BIN_DIR}/openwrt-$2-uImage" >"${TMP_DIR}/$2_webupgrade/$2.par"
echo ":rootfs 0 ${KDIR}/root.$1" >>"${TMP_DIR}/$2_webupgrade/$2.par"
- # create webupgrade file
+# create webupgrade image
( cd "${TMP_DIR}/$2_webupgrade"; \
"${STAGING_DIR_HOST}/bin/$2-builder" \
-v "${TMP_DIR}/$2_webupgrade/$2.par" \
- "${BIN_DIR}/openwrt-$2-$(1)-webupgrade.img"; \
- $(CP) openwrt-$2-$(1)-webupgrade.bin $(BIN_DIR)/openwrt-$2-$(1)-recovery.bin; \
+ "${BIN_DIR}/openwrt-$2-$1-webupgrade.img"; \
)
+# copy bin file as recovery image
+ $(CP) "${TMP_DIR}/$2_webupgrade/openwrt-$2-$1-webupgrade.bin" "$(BIN_DIR)/openwrt-$2-$1-recovery.bin"
rm -rf "${TMP_DIR}/$2_webupgrade"
endef
@@ -96,3 +98,8 @@ define Image/Build/squashfs
endef
$(eval $(call BuildImage))
+
+# Dependency for WRT350N v2 webupgrade image
+$(eval $(call RequireCommand,zip, \
+ Please install zip. \
+))