summaryrefslogtreecommitdiffstats
path: root/target/linux/orion/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-07-21 02:30:46 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-07-21 02:30:46 +0000
commit7f63e704b3b6c0012d7363ac99cec12c1500968d (patch)
tree37100218701d0a4e80c3665e9426350f353f4264 /target/linux/orion/image
parent92b9955e57efdfe4672cf46832cbf9106b7fa5fe (diff)
downloadmaster-31e0f0ae-7f63e704b3b6c0012d7363ac99cec12c1500968d.tar.gz
master-31e0f0ae-7f63e704b3b6c0012d7363ac99cec12c1500968d.tar.bz2
master-31e0f0ae-7f63e704b3b6c0012d7363ac99cec12c1500968d.zip
orion: fix image build on non-linux systems
SVN-Revision: 16938
Diffstat (limited to 'target/linux/orion/image')
-rw-r--r--target/linux/orion/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/orion/image/Makefile b/target/linux/orion/image/Makefile
index 66edc04331..21d01a105a 100644
--- a/target/linux/orion/image/Makefile
+++ b/target/linux/orion/image/Makefile
@@ -57,7 +57,7 @@ define Image/Build/Freecom
$(CP) $(KDIR)/dt2-uImage $(TARGET_DIR)/boot/uImage
rm -rf $(TARGET_DIR)/{var,jffs,rom}
$(INSTALL_DIR) $(TARGET_DIR)/var
- $(TAR) cfj $(BIN_DIR)/openwrt-$(2)-$(1).img --owner=root --group=root -C $(TARGET_DIR)/ .
+ $(TAR) cfj $(BIN_DIR)/openwrt-$(2)-$(1).img --numeric-owner --owner=0 --group=0 -C $(TARGET_DIR)/ .
$(STAGING_DIR_HOST)/bin/encode_crc $(BIN_DIR)/openwrt-$(2)-$(1).img $(BIN_DIR)/openwrt-$(2)-$(1)-webupgrade.img $(3)
endef