summaryrefslogtreecommitdiffstats
path: root/target/linux/orion/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2013-06-04 11:13:18 +0000
committerImre Kaloz <kaloz@openwrt.org>2013-06-04 11:13:18 +0000
commit58fa46c90c4c590565b3ffc5fc6c6dfd1e3d2c8a (patch)
tree53fcdcb3da2d812d904cf0d2a35ce846d287adea /target/linux/orion/image
parent6f6030825758273b3f6fa659470801fbc24a2789 (diff)
downloadmaster-31e0f0ae-58fa46c90c4c590565b3ffc5fc6c6dfd1e3d2c8a.tar.gz
master-31e0f0ae-58fa46c90c4c590565b3ffc5fc6c6dfd1e3d2c8a.tar.bz2
master-31e0f0ae-58fa46c90c4c590565b3ffc5fc6c6dfd1e3d2c8a.zip
drop support for the dns323
SVN-Revision: 36832
Diffstat (limited to 'target/linux/orion/image')
-rw-r--r--target/linux/orion/image/dns323.mk36
1 files changed, 0 insertions, 36 deletions
diff --git a/target/linux/orion/image/dns323.mk b/target/linux/orion/image/dns323.mk
deleted file mode 100644
index c33e612956..0000000000
--- a/target/linux/orion/image/dns323.mk
+++ /dev/null
@@ -1,36 +0,0 @@
-#
-# Copyright (C) 2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Image/Prepare
- cp $(LINUX_DIR)/arch/arm/boot/uImage $(KDIR)/uImage
-endef
-
-define Image/BuildKernel
- # Orion Kernel uImages
- # DNS-323: mach id 1542 (0x606)
- echo -en "\x06\x1c\xa0\xe3\x06\x10\x81\xe3" > $(KDIR)/dns323-zImage
- cat $(LINUX_DIR)/arch/arm/boot/zImage >> $(KDIR)/dns323-zImage
- $(STAGING_DIR_HOST)/bin/mkimage -A arm -O linux -T kernel \
- -C none -a 0x00008000 -e 0x00008000 -n 'Linux-$(LINUX_VERSION)' \
- -d $(KDIR)/dns323-zImage $(KDIR)/dns323-uImage
- cp $(KDIR)/dns323-uImage $(BIN_DIR)/openwrt-dns323-uImage
-endef
-
-define Image/Build/D-Link
- # Orion DNS-323 Images
- # mtd image
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-dns323-rootfs bs=128k
-endef
-
-define Image/Build
-$(call Image/Build/$(1),$(1))
-$(call Image/Build/D-Link,$(1),dns323,DNS-323,$(1))
-endef
-
-define Image/Build/squashfs
-$(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
-endef