summaryrefslogtreecommitdiffstats
path: root/target/linux/omap
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-02-12 10:51:46 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-02-12 10:51:46 +0000
commit836174c22f147d116d2f2b204126276af1d3e44c (patch)
tree507a0e589b01de32c53818883aee38f5990d2556 /target/linux/omap
parent936166c04296d5d9c651f5edd34c5c892a5f088c (diff)
downloadmaster-31e0f0ae-836174c22f147d116d2f2b204126276af1d3e44c.tar.gz
master-31e0f0ae-836174c22f147d116d2f2b204126276af1d3e44c.tar.bz2
master-31e0f0ae-836174c22f147d116d2f2b204126276af1d3e44c.zip
copy initramfs zImage to the bin dir as well
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 39577
Diffstat (limited to 'target/linux/omap')
-rw-r--r--target/linux/omap/image/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/target/linux/omap/image/Makefile b/target/linux/omap/image/Makefile
index 91b9df3b57..e681b04267 100644
--- a/target/linux/omap/image/Makefile
+++ b/target/linux/omap/image/Makefile
@@ -11,7 +11,10 @@ UBIFS_OPTS = -F -m 2048 -e 124KiB -c 4096 -U
UBI_OPTS = -m 2048 -p 128KiB -s 512 -O 2048
define Image/BuildKernel
- cp $(KDIR)/zImage $(BIN_DIR)/openwrt-$(BOARD)-zImage
+ $(CP) $(KDIR)/zImage $(BIN_DIR)/openwrt-$(BOARD)-zImage
+ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
+ $(CP) $(KDIR)/zImage-initramfs $(BIN_DIR)/openwrt-$(BOARD)-zImage-initramfs
+ endif
-mkdir $(BIN_DIR)/dtbs
-$(CP) $(LINUX_DIR)/arch/arm/boot/dts/am335x*.dtb $(BIN_DIR)/dtbs/
-$(CP) $(LINUX_DIR)/arch/arm/boot/dts/omap3*.dtb $(BIN_DIR)/dtbs/