summaryrefslogtreecommitdiffstats
path: root/target/linux/omap24xx
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2013-06-05 20:58:55 +0000
committerJonas Gorski <jogo@openwrt.org>2013-06-05 20:58:55 +0000
commitdd9a24663bf50265d6b87709f04f6a083083492e (patch)
tree7fe76fc16ef3b5c0e7ad005cb53b99894ddfbbdc /target/linux/omap24xx
parente7b504ce8e13d58a80472aa699c099bccb883cd3 (diff)
downloadmaster-31e0f0ae-dd9a24663bf50265d6b87709f04f6a083083492e.tar.gz
master-31e0f0ae-dd9a24663bf50265d6b87709f04f6a083083492e.tar.bz2
master-31e0f0ae-dd9a24663bf50265d6b87709f04f6a083083492e.zip
omap24xx: convert to use the new jffs2_nand
Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 36862
Diffstat (limited to 'target/linux/omap24xx')
-rw-r--r--target/linux/omap24xx/Makefile2
-rw-r--r--target/linux/omap24xx/image/Makefile4
2 files changed, 2 insertions, 4 deletions
diff --git a/target/linux/omap24xx/Makefile b/target/linux/omap24xx/Makefile
index 7a7e4d8bf3..5998b4db7e 100644
--- a/target/linux/omap24xx/Makefile
+++ b/target/linux/omap24xx/Makefile
@@ -10,7 +10,7 @@ ARCH:=arm
BOARD:=omap24xx
BOARDNAME:=TI OMAP24xx
MAINTAINER:=Michael Buesch <m@bues.ch>
-FEATURES:=targz squashfs jffs2 usb usbgadget display gpio audio broken
+FEATURES:=targz squashfs jffs2_nand usb usbgadget display gpio audio broken
LINUX_VERSION:=3.3.8
diff --git a/target/linux/omap24xx/image/Makefile b/target/linux/omap24xx/image/Makefile
index 682109a249..24e9b76744 100644
--- a/target/linux/omap24xx/image/Makefile
+++ b/target/linux/omap24xx/image/Makefile
@@ -7,9 +7,7 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-JFFS2_BLOCKSIZE=128k
-JFFS2OPTS += --little-endian --pagesize=0x800 --no-cleanmarkers --pad
-
+NAND_BLOCKSIZE=2048:128k
define Image/BuildKernel
$(CP) $(LINUX_DIR)/arch/arm/boot/zImage $(BIN_DIR)/$(IMG_PREFIX)-zImage