summaryrefslogtreecommitdiffstats
path: root/target/linux/omap24xx
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2012-01-13 14:38:28 +0000
committerJonas Gorski <jogo@openwrt.org>2012-01-13 14:38:28 +0000
commitc560444a584adf9efc36ba78eead9fc3e4afdd66 (patch)
tree6db0004fa55454faf536bfeb3bce26a066edeae4 /target/linux/omap24xx
parente49d3e1d5bdbaabe80dd0e3d0b4da93b2914461e (diff)
downloadmaster-31e0f0ae-c560444a584adf9efc36ba78eead9fc3e4afdd66.tar.gz
master-31e0f0ae-c560444a584adf9efc36ba78eead9fc3e4afdd66.tar.bz2
master-31e0f0ae-c560444a584adf9efc36ba78eead9fc3e4afdd66.zip
kernel: update linux 3.1 to 3.1.9
SVN-Revision: 29726
Diffstat (limited to 'target/linux/omap24xx')
-rw-r--r--target/linux/omap24xx/Makefile2
-rw-r--r--target/linux/omap24xx/patches-3.1/210-omap2-kexec-rewrite.patch14
-rw-r--r--target/linux/omap24xx/patches-3.1/850-musb-tusb-modular-fixes.patch6
3 files changed, 11 insertions, 11 deletions
diff --git a/target/linux/omap24xx/Makefile b/target/linux/omap24xx/Makefile
index e891b89cb6..087c707754 100644
--- a/target/linux/omap24xx/Makefile
+++ b/target/linux/omap24xx/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=TI OMAP-24xx
MAINTAINER:=Michael Buesch <m@bues.ch>
FEATURES:=targz squashfs jffs2 usb usbgadget display gpio audio
-LINUX_VERSION:=3.1.4
+LINUX_VERSION:=3.1.9
define Target/Description
TI OMAP-24xx
diff --git a/target/linux/omap24xx/patches-3.1/210-omap2-kexec-rewrite.patch b/target/linux/omap24xx/patches-3.1/210-omap2-kexec-rewrite.patch
index 6da3478dcb..0c26af2ab1 100644
--- a/target/linux/omap24xx/patches-3.1/210-omap2-kexec-rewrite.patch
+++ b/target/linux/omap24xx/patches-3.1/210-omap2-kexec-rewrite.patch
@@ -1,6 +1,6 @@
--- a/arch/arm/Kconfig
+++ b/arch/arm/Kconfig
-@@ -1876,7 +1876,7 @@ config XIP_PHYS_ADDR
+@@ -1888,7 +1888,7 @@ config XIP_PHYS_ADDR
config KEXEC
bool "Kexec system call (EXPERIMENTAL)"
@@ -201,7 +201,7 @@
EXPORT_SYMBOL_GPL(arm_pm_restart);
static void do_nothing(void *unused)
-@@ -250,7 +274,15 @@ void machine_power_off(void)
+@@ -253,7 +277,15 @@ void machine_power_off(void)
void machine_restart(char *cmd)
{
machine_shutdown();
@@ -219,10 +219,10 @@
void __show_regs(struct pt_regs *regs)
--- a/arch/arm/kernel/setup.c
+++ b/arch/arm/kernel/setup.c
-@@ -890,8 +890,8 @@ void __init setup_arch(char **cmdline_p)
- machine_desc = mdesc;
- machine_name = mdesc->name;
-
+@@ -896,8 +896,8 @@ void __init setup_arch(char **cmdline_p)
+ arm_dma_zone_size = mdesc->dma_zone_size;
+ }
+ #endif
- if (mdesc->soft_reboot)
- reboot_setup("s");
+ if (mdesc->restart_mode)
@@ -230,7 +230,7 @@
init_mm.start_code = (unsigned long) _text;
init_mm.end_code = (unsigned long) _etext;
-@@ -910,6 +910,9 @@ void __init setup_arch(char **cmdline_p)
+@@ -916,6 +916,9 @@ void __init setup_arch(char **cmdline_p)
paging_init(mdesc);
request_standard_resources(mdesc);
diff --git a/target/linux/omap24xx/patches-3.1/850-musb-tusb-modular-fixes.patch b/target/linux/omap24xx/patches-3.1/850-musb-tusb-modular-fixes.patch
index c958989bf7..afdea788ee 100644
--- a/target/linux/omap24xx/patches-3.1/850-musb-tusb-modular-fixes.patch
+++ b/target/linux/omap24xx/patches-3.1/850-musb-tusb-modular-fixes.patch
@@ -79,7 +79,7 @@
hw_ep->fifo_async = musb->async + 0x400 + MUSB_FIFO_OFFSET(i);
hw_ep->fifo_sync = musb->sync + 0x400 + MUSB_FIFO_OFFSET(i);
hw_ep->fifo_sync_va =
-@@ -2376,8 +2376,13 @@ static struct platform_driver musb_drive
+@@ -2368,8 +2368,13 @@ static struct platform_driver musb_drive
/*-------------------------------------------------------------------------*/
@@ -93,7 +93,7 @@
if (usb_disabled())
return 0;
-@@ -2386,7 +2391,17 @@ static int __init musb_init(void)
+@@ -2378,7 +2383,17 @@ static int __init musb_init(void)
", "
"otg (peripheral+host)",
musb_driver_name);
@@ -112,7 +112,7 @@
}
/* make us init after usbcore and i2c (transceivers, regulators, etc)
-@@ -2397,5 +2412,6 @@ fs_initcall(musb_init);
+@@ -2389,5 +2404,6 @@ fs_initcall(musb_init);
static void __exit musb_cleanup(void)
{
platform_driver_unregister(&musb_driver);