summaryrefslogtreecommitdiffstats
path: root/target/linux/omap24xx
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-06-27 19:58:31 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-06-27 19:58:31 +0000
commit6a4f2922f6303a006d66b4bbb79541823b1c12b4 (patch)
treed3d9644c2a4a2e9b758bab9b84973e078143ed2c /target/linux/omap24xx
parenteab95ea46736f8359c5a19a612f0e39160cab80c (diff)
downloadmaster-31e0f0ae-6a4f2922f6303a006d66b4bbb79541823b1c12b4.tar.gz
master-31e0f0ae-6a4f2922f6303a006d66b4bbb79541823b1c12b4.tar.bz2
master-31e0f0ae-6a4f2922f6303a006d66b4bbb79541823b1c12b4.zip
targets: prepare for supporting normal and initramfs images
In order to support both normal images and initramfs, ensure that each target sets KERNELNAME properly so that the generic kernel building code can copy the corresponding files over $(KDIR) with the appropriate extension. Update the various paths to the kernel and wrapper images from $(LINUX_DIR)/arch/$(ARCH)/boot/$(foo) to $(KDIR)/$(foo). Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 37049
Diffstat (limited to 'target/linux/omap24xx')
-rw-r--r--target/linux/omap24xx/Makefile2
-rw-r--r--target/linux/omap24xx/image/Makefile2
2 files changed, 3 insertions, 1 deletions
diff --git a/target/linux/omap24xx/Makefile b/target/linux/omap24xx/Makefile
index 5998b4db7e..a91b0d2d13 100644
--- a/target/linux/omap24xx/Makefile
+++ b/target/linux/omap24xx/Makefile
@@ -20,6 +20,8 @@ endef
CFLAGS:=-Os -pipe -march=armv6 -mtune=arm1136j-s -fno-caller-saves
+KERNELNAME:="zImage"
+
include $(INCLUDE_DIR)/target.mk
$(eval $(call BuildTarget))
diff --git a/target/linux/omap24xx/image/Makefile b/target/linux/omap24xx/image/Makefile
index 24e9b76744..96dc854231 100644
--- a/target/linux/omap24xx/image/Makefile
+++ b/target/linux/omap24xx/image/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/image.mk
NAND_BLOCKSIZE=2048:128k
define Image/BuildKernel
- $(CP) $(LINUX_DIR)/arch/arm/boot/zImage $(BIN_DIR)/$(IMG_PREFIX)-zImage
+ $(CP) $(KDIR)/zImage $(BIN_DIR)/$(IMG_PREFIX)-zImage
chmod 0644 $(BIN_DIR)/$(IMG_PREFIX)-zImage
endef