summaryrefslogtreecommitdiffstats
path: root/target/linux/omap24xx
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-07-24 19:43:45 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-07-24 19:43:45 +0000
commit25e20b0b57b32fb7a38e1e9a5b319617f3947932 (patch)
tree994937317ebd3dc13f4e89592ce440d6d6ec8de4 /target/linux/omap24xx
parent587f85ac2018295a078c6d27255c66bf624b8897 (diff)
downloadmaster-31e0f0ae-25e20b0b57b32fb7a38e1e9a5b319617f3947932.tar.gz
master-31e0f0ae-25e20b0b57b32fb7a38e1e9a5b319617f3947932.tar.bz2
master-31e0f0ae-25e20b0b57b32fb7a38e1e9a5b319617f3947932.zip
move target specific modules to target's module.mk
SVN-Revision: 32808
Diffstat (limited to 'target/linux/omap24xx')
-rw-r--r--target/linux/omap24xx/modules.mk46
1 files changed, 46 insertions, 0 deletions
diff --git a/target/linux/omap24xx/modules.mk b/target/linux/omap24xx/modules.mk
new file mode 100644
index 0000000000..1664e05c89
--- /dev/null
+++ b/target/linux/omap24xx/modules.mk
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/sound-soc-omap
+ TITLE:=OMAP SoC sound support
+ KCONFIG:= \
+ CONFIG_SND_OMAP_SOC
+ FILES:=$(LINUX_DIR)/sound/soc/omap/snd-soc-omap.ko
+ AUTOLOAD:=$(call AutoLoad,60,snd-soc-omap)
+ DEPENDS:=@TARGET_omap24xx +kmod-sound-soc-core
+ $(call AddDepends/sound)
+endef
+
+$(eval $(call KernelPackage,sound-soc-omap))
+
+
+define KernelPackage/sound-soc-omap-mcbsp
+ TITLE:=OMAP SoC MCBSP support
+ KCONFIG:= \
+ CONFIG_SND_OMAP_SOC_MCBSP
+ FILES:=$(LINUX_DIR)/sound/soc/omap/snd-soc-omap-mcbsp.ko
+ AUTOLOAD:=$(call AutoLoad,61,snd-soc-omap-mcbsp)
+ DEPENDS:=@TARGET_omap24xx +kmod-sound-soc-omap
+ $(call AddDepends/sound)
+endef
+
+$(eval $(call KernelPackage,sound-soc-omap-mcbsp))
+
+
+define KernelPackage/sound-soc-n810
+ TITLE:=Nokia n810 SoC sound support
+ KCONFIG:= \
+ CONFIG_SND_OMAP_SOC_N810
+ FILES:= \
+ $(LINUX_DIR)/sound/soc/codecs/snd-soc-tlv320aic3x.ko \
+ $(LINUX_DIR)/sound/soc/omap/snd-soc-n810.ko
+ AUTOLOAD:=$(call AutoLoad,65,snd-soc-tlv320aic3x snd-soc-n810)
+ DEPENDS:=@TARGET_omap24xx +kmod-sound-soc-omap +kmod-sound-soc-omap-mcbsp
+ $(call AddDepends/sound)
+endef
+
+$(eval $(call KernelPackage,sound-soc-n810))