summaryrefslogtreecommitdiffstats
path: root/target/linux/omap24xx/profiles
diff options
context:
space:
mode:
authorMichael Büsch <mb@bu3sch.de>2010-08-26 19:54:08 +0000
committerMichael Büsch <mb@bu3sch.de>2010-08-26 19:54:08 +0000
commite483dd283690de4fe411b8400ca833d425330dfc (patch)
treeec45aa39208fafef76bcd9ab715bea694e4c0e96 /target/linux/omap24xx/profiles
parent76d517b6299e7fde412e944164081b499ba6e2ca (diff)
downloadmaster-31e0f0ae-e483dd283690de4fe411b8400ca833d425330dfc.tar.gz
master-31e0f0ae-e483dd283690de4fe411b8400ca833d425330dfc.tar.bz2
master-31e0f0ae-e483dd283690de4fe411b8400ca833d425330dfc.zip
Improve n810 profile
SVN-Revision: 22817
Diffstat (limited to 'target/linux/omap24xx/profiles')
-rw-r--r--target/linux/omap24xx/profiles/100-n810.mk20
-rw-r--r--target/linux/omap24xx/profiles/110-n810-gui.mk22
2 files changed, 36 insertions, 6 deletions
diff --git a/target/linux/omap24xx/profiles/100-n810.mk b/target/linux/omap24xx/profiles/100-n810.mk
index 6eddc0501d..f424b9723b 100644
--- a/target/linux/omap24xx/profiles/100-n810.mk
+++ b/target/linux/omap24xx/profiles/100-n810.mk
@@ -5,13 +5,21 @@
# See /LICENSE for more information.
#
-define Profile/n810
- NAME:=Nokia n810
- PACKAGES:=
+define Profile/n810-base
+ NAME:=Nokia n810 (base)
+ PACKAGES:= \
+ block-hotplug \
+ gpsd \
+ ip iw wireless-tools kmod-p54-spi wpa-supplicant \
+ dnsmasq dropbear \
+ kmod-fs-vfat kmod-fs-msdos \
+ kmod-input-evdev \
+ kmod-leds-gpio \
+ kmod-usb-tahvo kmod-usb-eth-gadget kmod-usb-net kmod-usb-net-cdc-ether
endef
-define Profile/n810/Description
- Package set compatible with Nokia n810 hardware
+define Profile/n810-base/Description
+ Minimal package set for Nokia n810 hardware.
endef
-$(eval $(call Profile,n810))
+$(eval $(call Profile,n810-base))
diff --git a/target/linux/omap24xx/profiles/110-n810-gui.mk b/target/linux/omap24xx/profiles/110-n810-gui.mk
new file mode 100644
index 0000000000..b04db3c9e5
--- /dev/null
+++ b/target/linux/omap24xx/profiles/110-n810-gui.mk
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/n810-gui
+ $(call Profile/n810-base)
+ NAME:=Nokia n810 (GUI)
+ PACKAGES+= \
+ xserver-xorg xinit xauth xterm \
+ xf86-video-omapfb xf86-input-tslib xf86-input-evdev \
+ openbox lxpanel \
+ pwrtray
+endef
+
+define Profile/n810-gui/Description
+ Graphical user interface package set for Nokia n810 hardware.
+endef
+$(eval $(call Profile,n810-gui))
+