summaryrefslogtreecommitdiffstats
path: root/target/linux/omap24xx/image
diff options
context:
space:
mode:
authorMichael Büsch <mb@bu3sch.de>2010-08-08 14:16:48 +0000
committerMichael Büsch <mb@bu3sch.de>2010-08-08 14:16:48 +0000
commit975ba9a88d9b529457e2b6bdced86d7918421bfe (patch)
tree964074a366eae48d03e086f03209799d7abac07f /target/linux/omap24xx/image
parentf2ef7cc8af1a7a983c90355c47df7d4b361bb600 (diff)
downloadmaster-31e0f0ae-975ba9a88d9b529457e2b6bdced86d7918421bfe.tar.gz
master-31e0f0ae-975ba9a88d9b529457e2b6bdced86d7918421bfe.tar.bz2
master-31e0f0ae-975ba9a88d9b529457e2b6bdced86d7918421bfe.zip
Add omap24xx.
Boots the kernel with working video and serial console. Userland is untested. SVN-Revision: 22530
Diffstat (limited to 'target/linux/omap24xx/image')
-rw-r--r--target/linux/omap24xx/image/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/omap24xx/image/Makefile b/target/linux/omap24xx/image/Makefile
new file mode 100644
index 0000000000..682109a249
--- /dev/null
+++ b/target/linux/omap24xx/image/Makefile
@@ -0,0 +1,29 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+JFFS2_BLOCKSIZE=128k
+JFFS2OPTS += --little-endian --pagesize=0x800 --no-cleanmarkers --pad
+
+
+define Image/BuildKernel
+ $(CP) $(LINUX_DIR)/arch/arm/boot/zImage $(BIN_DIR)/$(IMG_PREFIX)-zImage
+ chmod 0644 $(BIN_DIR)/$(IMG_PREFIX)-zImage
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(BIN_DIR)/$(IMG_PREFIX)-root.$(1))
+endef
+
+define Image/Build
+ $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-root.$(1)
+ $(call Image/Build/$(1),$(1))
+endef
+
+
+$(eval $(call BuildImage))