summaryrefslogtreecommitdiffstats
path: root/target/linux/omap24xx/image
diff options
context:
space:
mode:
authorMichael Büsch <mb@bu3sch.de>2015-10-09 07:46:12 +0000
committerMichael Büsch <mb@bu3sch.de>2015-10-09 07:46:12 +0000
commit56ee70637922e3db6bfe9ecdb73e819c10fd71dd (patch)
tree4ba28e69c7d21a624c73bfc28d048c605feac080 /target/linux/omap24xx/image
parent8bb23cfb663f8870f431edba0dab218a746456a3 (diff)
downloadmaster-31e0f0ae-56ee70637922e3db6bfe9ecdb73e819c10fd71dd.tar.gz
master-31e0f0ae-56ee70637922e3db6bfe9ecdb73e819c10fd71dd.tar.bz2
master-31e0f0ae-56ee70637922e3db6bfe9ecdb73e819c10fd71dd.zip
omap24xx: Append dtb to the zImage
We just hardcode the n810 dtb for now. It should be selectable via profiles. SVN-Revision: 47166
Diffstat (limited to 'target/linux/omap24xx/image')
-rw-r--r--target/linux/omap24xx/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/omap24xx/image/Makefile b/target/linux/omap24xx/image/Makefile
index 7a3429fa6c..316cce0f9f 100644
--- a/target/linux/omap24xx/image/Makefile
+++ b/target/linux/omap24xx/image/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/image.mk
NAND_BLOCKSIZE=2048-128k
define Image/BuildKernel
- $(CP) $(KDIR)/zImage $(BIN_DIR)/$(IMG_PREFIX)-zImage
+ cat $(KDIR)/zImage $(DTS_DIR)/omap2420-n810.dtb > $(BIN_DIR)/$(IMG_PREFIX)-zImage
chmod 0644 $(BIN_DIR)/$(IMG_PREFIX)-zImage
endef