summaryrefslogtreecommitdiffstats
path: root/target/linux/omap24xx/Makefile
diff options
context:
space:
mode:
authorMichael Büsch <mb@bu3sch.de>2010-08-08 14:16:48 +0000
committerMichael Büsch <mb@bu3sch.de>2010-08-08 14:16:48 +0000
commit975ba9a88d9b529457e2b6bdced86d7918421bfe (patch)
tree964074a366eae48d03e086f03209799d7abac07f /target/linux/omap24xx/Makefile
parentf2ef7cc8af1a7a983c90355c47df7d4b361bb600 (diff)
downloadmaster-31e0f0ae-975ba9a88d9b529457e2b6bdced86d7918421bfe.tar.gz
master-31e0f0ae-975ba9a88d9b529457e2b6bdced86d7918421bfe.tar.bz2
master-31e0f0ae-975ba9a88d9b529457e2b6bdced86d7918421bfe.zip
Add omap24xx.
Boots the kernel with working video and serial console. Userland is untested. SVN-Revision: 22530
Diffstat (limited to 'target/linux/omap24xx/Makefile')
-rw-r--r--target/linux/omap24xx/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/omap24xx/Makefile b/target/linux/omap24xx/Makefile
new file mode 100644
index 0000000000..2d04d7c80c
--- /dev/null
+++ b/target/linux/omap24xx/Makefile
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=omap24xx
+BOARDNAME:=TI OMAP-24xx
+FEATURES:=jffs2
+
+LINUX_VERSION:=2.6.35
+
+define Target/Description
+ TI OMAP-24xx
+endef
+
+include $(INCLUDE_DIR)/target.mk
+
+$(eval $(call BuildTarget))