summaryrefslogtreecommitdiffstats
path: root/target/linux/octeon
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-29 23:19:36 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-29 23:19:36 +0000
commitf32de94e0a46e06586dfd4066465a9425fa64304 (patch)
tree956d0465c8d737454e27f13d31efb439e6620d9f /target/linux/octeon
parent3e9d2a847bbbc282e82a2a92417a095ad1e21e1a (diff)
downloadmaster-31e0f0ae-f32de94e0a46e06586dfd4066465a9425fa64304.tar.gz
master-31e0f0ae-f32de94e0a46e06586dfd4066465a9425fa64304.tar.bz2
master-31e0f0ae-f32de94e0a46e06586dfd4066465a9425fa64304.zip
octeon: update to linux 4.4
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 48557
Diffstat (limited to 'target/linux/octeon')
-rw-r--r--target/linux/octeon/Makefile2
-rw-r--r--target/linux/octeon/config-4.4 (renamed from target/linux/octeon/config-4.3)20
-rw-r--r--target/linux/octeon/patches-4.4/100-ubnt_edgerouter2_support.patch (renamed from target/linux/octeon/patches-4.3/100-ubnt_edgerouter2_support.patch)0
-rw-r--r--target/linux/octeon/patches-4.4/110-er200-ethernet_probe_order.patch (renamed from target/linux/octeon/patches-4.3/110-er200-ethernet_probe_order.patch)4
-rw-r--r--target/linux/octeon/patches-4.4/150-mmc-octeon-add-host-driver-for-octeon-mmc-controller.patch (renamed from target/linux/octeon/patches-4.3/150-mmc-octeon-add-host-driver-for-octeon-mmc-controller.patch)0
-rw-r--r--target/linux/octeon/patches-4.4/160-cmdline-hack.patch (renamed from target/linux/octeon/patches-4.3/160-cmdline-hack.patch)0
6 files changed, 14 insertions, 12 deletions
diff --git a/target/linux/octeon/Makefile b/target/linux/octeon/Makefile
index a6707f0050..21c11dc061 100644
--- a/target/linux/octeon/Makefile
+++ b/target/linux/octeon/Makefile
@@ -14,7 +14,7 @@ CPU_TYPE:=octeon
CPU_CFLAGS_octeon:=-march=octeon -mabi=64
MAINTAINER:=John Crispin <blogic@openwrt.org>
-KERNEL_PATCHVER:=4.3
+KERNEL_PATCHVER:=4.4
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/octeon/config-4.3 b/target/linux/octeon/config-4.4
index f8702f5328..19659c3349 100644
--- a/target/linux/octeon/config-4.3
+++ b/target/linux/octeon/config-4.4
@@ -1,5 +1,6 @@
CONFIG_64BIT=y
CONFIG_ARCH_BINFMT_ELF_STATE=y
+CONFIG_ARCH_CLOCKSOURCE_DATA=y
CONFIG_ARCH_DISCARD_MEMBLOCK=y
CONFIG_ARCH_DMA_ADDR_T_64BIT=y
CONFIG_ARCH_HAS_ATOMIC64_DEC_IF_POSITIVE=y
@@ -14,6 +15,7 @@ CONFIG_ARCH_REQUIRE_GPIOLIB=y
CONFIG_ARCH_SPARSEMEM_ENABLE=y
CONFIG_ARCH_SUPPORTS_UPROBES=y
CONFIG_ARCH_SUSPEND_POSSIBLE=y
+CONFIG_ARCH_USE_BUILTIN_BSWAP=y
CONFIG_ARCH_USE_CMPXCHG_LOCKREF=y
CONFIG_ARCH_WANT_COMPAT_IPC_PARSE_VERSION=y
CONFIG_ARCH_WANT_IPC_PARSE_VERSION=y
@@ -24,7 +26,7 @@ CONFIG_BLOCK_COMPAT=y
# CONFIG_BOOTPARAM_HUNG_TASK_PANIC is not set
CONFIG_BOOTPARAM_HUNG_TASK_PANIC_VALUE=0
CONFIG_BUILTIN_DTB=y
-# CONFIG_CAVIUM_CN63XXP1 is not set
+CONFIG_CAVIUM_CN63XXP1=y
# CONFIG_CAVIUM_OCTEON_2ND_KERNEL is not set
CONFIG_CAVIUM_OCTEON_CVMSEG_SIZE=2
CONFIG_CAVIUM_OCTEON_LOCK_L2=y
@@ -85,6 +87,7 @@ CONFIG_GENERIC_IO=y
CONFIG_GENERIC_IRQ_SHOW=y
CONFIG_GENERIC_PCI_IOMAP=y
CONFIG_GENERIC_SMP_IDLE_THREAD=y
+CONFIG_GENERIC_TIME_VSYSCALL=y
CONFIG_GPIOLIB=y
CONFIG_GPIO_DEVRES=y
CONFIG_GPIO_OCTEON=y
@@ -117,6 +120,7 @@ CONFIG_HAVE_FUNCTION_TRACER=y
CONFIG_HAVE_GENERIC_DMA_COHERENT=y
CONFIG_HAVE_IDE=y
CONFIG_HAVE_IRQ_TIME_ACCOUNTING=y
+CONFIG_HAVE_LATENCYTOP_SUPPORT=y
CONFIG_HAVE_MEMBLOCK=y
CONFIG_HAVE_MEMBLOCK_NODE_MAP=y
CONFIG_HAVE_MEMORY_PRESENT=y
@@ -147,18 +151,19 @@ CONFIG_JBD2=y
CONFIG_KALLSYMS=y
CONFIG_KEXEC=y
CONFIG_KEXEC_CORE=y
-CONFIG_KVM_COMPAT=y
CONFIG_LIBFDT=y
# CONFIG_LIQUIDIO is not set
-# CONFIG_MACH_INGENIC is not set
-# CONFIG_MACH_LOONGSON32 is not set
-# CONFIG_MACH_LOONGSON64 is not set
CONFIG_MDIO_BOARDINFO=y
CONFIG_MDIO_OCTEON=y
CONFIG_MIPS=y
CONFIG_MIPS32_COMPAT=y
CONFIG_MIPS32_N32=y
CONFIG_MIPS32_O32=y
+# CONFIG_MIPS_CLOCK_VSYSCALL is not set
+# CONFIG_MIPS_CMDLINE_DTB_EXTEND is not set
+CONFIG_MIPS_CMDLINE_FROM_BOOTLOADER=y
+# CONFIG_MIPS_CMDLINE_FROM_DTB is not set
+# CONFIG_MIPS_ELF_APPENDED_DTB is not set
# CONFIG_MIPS_HUGE_TLB_SUPPORT is not set
CONFIG_MIPS_L1_CACHE_SHIFT=7
CONFIG_MIPS_L1_CACHE_SHIFT_7=y
@@ -203,7 +208,6 @@ CONFIG_OF_MTD=y
CONFIG_OF_NET=y
CONFIG_OF_PCI=y
CONFIG_OF_PCI_IRQ=y
-CONFIG_PAGEFLAGS_EXTENDED=y
# CONFIG_PARTITION_ADVANCED is not set
CONFIG_PCI=y
CONFIG_PCI_BUS_ADDR_T_64BIT=y
@@ -226,13 +230,11 @@ CONFIG_SCSI=y
CONFIG_SECCOMP=y
CONFIG_SECCOMP_FILTER=y
CONFIG_SERIAL_8250_DW=y
-# CONFIG_SG_SPLIT is not set
+# CONFIG_SERIAL_8250_FSL is not set
CONFIG_SMP=y
CONFIG_SPARSEMEM=y
CONFIG_SPARSEMEM_STATIC=y
CONFIG_SRCU=y
-CONFIG_STOP_MACHINE=y
-# CONFIG_SUNXI_SRAM is not set
CONFIG_SWAP_IO_SPACE=y
CONFIG_SWIOTLB=y
CONFIG_SYSCTL_EXCEPTION_TRACE=y
diff --git a/target/linux/octeon/patches-4.3/100-ubnt_edgerouter2_support.patch b/target/linux/octeon/patches-4.4/100-ubnt_edgerouter2_support.patch
index 662fbd27f1..662fbd27f1 100644
--- a/target/linux/octeon/patches-4.3/100-ubnt_edgerouter2_support.patch
+++ b/target/linux/octeon/patches-4.4/100-ubnt_edgerouter2_support.patch
diff --git a/target/linux/octeon/patches-4.3/110-er200-ethernet_probe_order.patch b/target/linux/octeon/patches-4.4/110-er200-ethernet_probe_order.patch
index 0bd8968a09..71d45a0f51 100644
--- a/target/linux/octeon/patches-4.3/110-er200-ethernet_probe_order.patch
+++ b/target/linux/octeon/patches-4.4/110-er200-ethernet_probe_order.patch
@@ -1,6 +1,6 @@
--- a/drivers/staging/octeon/ethernet.c
+++ b/drivers/staging/octeon/ethernet.c
-@@ -663,6 +663,7 @@ static int cvm_oct_probe(struct platform
+@@ -667,6 +667,7 @@ static int cvm_oct_probe(struct platform
int interface;
int fau = FAU_NUM_PACKET_BUFFERS_TO_FREE;
int qos;
@@ -8,7 +8,7 @@
struct device_node *pip;
octeon_mdiobus_force_mod_depencency();
-@@ -747,13 +748,19 @@ static int cvm_oct_probe(struct platform
+@@ -751,13 +752,19 @@ static int cvm_oct_probe(struct platform
}
num_interfaces = cvmx_helper_get_number_of_interfaces();
diff --git a/target/linux/octeon/patches-4.3/150-mmc-octeon-add-host-driver-for-octeon-mmc-controller.patch b/target/linux/octeon/patches-4.4/150-mmc-octeon-add-host-driver-for-octeon-mmc-controller.patch
index 62e5ef858a..62e5ef858a 100644
--- a/target/linux/octeon/patches-4.3/150-mmc-octeon-add-host-driver-for-octeon-mmc-controller.patch
+++ b/target/linux/octeon/patches-4.4/150-mmc-octeon-add-host-driver-for-octeon-mmc-controller.patch
diff --git a/target/linux/octeon/patches-4.3/160-cmdline-hack.patch b/target/linux/octeon/patches-4.4/160-cmdline-hack.patch
index 6e042ef714..6e042ef714 100644
--- a/target/linux/octeon/patches-4.3/160-cmdline-hack.patch
+++ b/target/linux/octeon/patches-4.4/160-cmdline-hack.patch