summaryrefslogtreecommitdiffstats
path: root/target/linux/octeon
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-05-23 15:28:20 +0000
committerJohn Crispin <john@openwrt.org>2015-05-23 15:28:20 +0000
commitab84e2d70455743ba457fff4e55fe14aec4a4d61 (patch)
tree2ea4243405d91ec54c527297ff532e2a2d413287 /target/linux/octeon
parentb4494d971387632a69541a2d61b16b65d22cb797 (diff)
downloadmaster-31e0f0ae-ab84e2d70455743ba457fff4e55fe14aec4a4d61.tar.gz
master-31e0f0ae-ab84e2d70455743ba457fff4e55fe14aec4a4d61.tar.bz2
master-31e0f0ae-ab84e2d70455743ba457fff4e55fe14aec4a4d61.zip
octeon: build squashfs image for UBNT ERLITE
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> SVN-Revision: 45732
Diffstat (limited to 'target/linux/octeon')
-rw-r--r--target/linux/octeon/image/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/target/linux/octeon/image/Makefile b/target/linux/octeon/image/Makefile
index 24bca9b48d..a15e87b0c9 100644
--- a/target/linux/octeon/image/Makefile
+++ b/target/linux/octeon/image/Makefile
@@ -20,24 +20,27 @@ define Image/BuildKernel/Initramfs/Template
endef
ER_CMDLINE:=-mtdparts=phys_mapped_flash:640k(boot0)ro,640k(boot1)ro,64k(eeprom)ro block2mtd.block2mtd=/dev/mmcblk0p2,65536,rootfs,5 root=/dev/mtdblock3 rootfstype=squashfs rootwait
+ERLITE_CMDLINE:=-mtdparts=phys_mapped_flash:512k(boot0),512k(boot1),64k@1024k(eeprom) block2mtd.block2mtd=/dev/sda2,65536,rootfs,5 root=/dev/mtdblock3 rootfstype=squashfs rootwait
define Image/BuildKernel
$(call Image/BuildKernel/Template,generic,)
$(call Image/BuildKernel/Template,er,$(ER_CMDLINE))
+ $(call Image/BuildKernel/Template,erlite,$(ERLITE_CMDLINE))
endef
define Image/BuildKernel/Initramfs
$(call Image/BuildKernel/Initramfs/Template,generic,)
$(call Image/BuildKernel/Initramfs/Template,er,$(ER_CMDLINE))
+ $(call Image/BuildKernel/Initramfs/Template,erlite,$(ERLITE_CMDLINE))
endef
define Image/Build/sysupgrade
mkdir -p $(KDIR)/sysupgrade-$(1)/
- echo "BOARD=er" > $(KDIR)/sysupgrade-$(1)/CONTROL
+ echo "BOARD=$(1)" > $(KDIR)/sysupgrade-$(1)/CONTROL
$(CP) $(BIN_DIR)/$(IMG_PREFIX)-$(2)-vmlinux.64 $(KDIR)/sysupgrade-$(1)/kernel
$(CP) $(KDIR)/root.$(3) $(KDIR)/sysupgrade-$(1)/root
(cd $(KDIR); $(TAR) cvf \
- $(BIN_DIR)/$(IMG_PREFIX)-$(1)-sysupgrade.tar sysupgrade-$(1))
+ $(BIN_DIR)/$(IMG_PREFIX)-$(1)-$(3)-sysupgrade.tar sysupgrade-$(1))
endef
define Image/Build/ext4
@@ -47,6 +50,7 @@ endef
define Image/Build/squashfs
$(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
$(call Image/Build/sysupgrade,er,er,squashfs)
+ $(call Image/Build/sysupgrade,erlite,erlite,squashfs)
endef
define Image/Build