summaryrefslogtreecommitdiffstats
path: root/target/linux/octeon
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-07-28 19:21:44 +0200
committerJo-Philipp Wich <jo@mein.io>2016-07-28 19:44:19 +0200
commit3bb2b46bc32f35e18eb5e656fa8dafa3e3434592 (patch)
treeb6f8464a0a29fe32bb2ad025faaf6950e4d30cfa /target/linux/octeon
parentadbbfb7ff900c489e6be34b2ec2834172dff7943 (diff)
downloadmaster-31e0f0ae-3bb2b46bc32f35e18eb5e656fa8dafa3e3434592.tar.gz
master-31e0f0ae-3bb2b46bc32f35e18eb5e656fa8dafa3e3434592.tar.bz2
master-31e0f0ae-3bb2b46bc32f35e18eb5e656fa8dafa3e3434592.zip
octeon: fix image build
After b47f438 "build: remove image prefix from kernel files in KDIR", the kernel image in $(KDIR) has a different name and could not be found by the tar-file build step anymore, leading to the following error on the build servers: cp: cannot stat `.../linux-octeon/lede-octeon-generic-kernel.bin': No such file or directory make[4]: *** [.../linux-octeon/tmp/lede-octeon-generic-ext4-sysupgrade.tar] Error 1 Adjust the path to the source kernel image in order to fix the problem. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'target/linux/octeon')
-rw-r--r--target/linux/octeon/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/octeon/image/Makefile b/target/linux/octeon/image/Makefile
index 89cbba592c..e2d6539ad3 100644
--- a/target/linux/octeon/image/Makefile
+++ b/target/linux/octeon/image/Makefile
@@ -22,7 +22,7 @@ endef
define Build/tar-file
mkdir -p $(KDIR)/sysupgrade-$(DEVICE_NAME)/
echo "BOARD=$(BOARD)" > $(KDIR)/sysupgrade-$(DEVICE_NAME)/CONTROL
- $(CP) $(KDIR)/$(KERNEL_IMAGE) $(KDIR)/sysupgrade-$(DEVICE_NAME)/kernel
+ $(CP) $(KDIR_KERNEL_IMAGE) $(KDIR)/sysupgrade-$(DEVICE_NAME)/kernel
$(CP) $(KDIR)/root.$(1) $(KDIR)/sysupgrade-$(DEVICE_NAME)/root
(cd $(KDIR); $(TAR) cvf \
$@ sysupgrade-$(DEVICE_NAME))