summaryrefslogtreecommitdiffstats
path: root/target/linux/octeon
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-04-24 13:34:51 +0000
committerNicolas Thill <nico@openwrt.org>2010-04-24 13:34:51 +0000
commit484051d05518b1f7fb53b535e84302849080272d (patch)
treed4fcbe83d1ea442b9b0a2470e95fc222536a114c /target/linux/octeon
parent9ae19dcf8799314a89c7eabd57304c046f50d513 (diff)
downloadmaster-31e0f0ae-484051d05518b1f7fb53b535e84302849080272d.tar.gz
master-31e0f0ae-484051d05518b1f7fb53b535e84302849080272d.tar.bz2
master-31e0f0ae-484051d05518b1f7fb53b535e84302849080272d.zip
package/kernel: move target specific modules to their own target files
SVN-Revision: 21132
Diffstat (limited to 'target/linux/octeon')
-rw-r--r--target/linux/octeon/modules.mk39
1 files changed, 39 insertions, 0 deletions
diff --git a/target/linux/octeon/modules.mk b/target/linux/octeon/modules.mk
new file mode 100644
index 0000000000..a161d68493
--- /dev/null
+++ b/target/linux/octeon/modules.mk
@@ -0,0 +1,39 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/ata-octeon-cf
+ SUBMENU:=$(BLOCK_MENU)
+ TITLE:=Octeon Compact Flash support
+ DEPENDS:=@TARGET_octeon
+ KCONFIG:=CONFIG_PATA_OCTEON_CF
+ FILES:=$(LINUX_DIR)/drivers/ata/pata_octeon_cf.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,41,pata_octeon_cf,1)
+ $(call AddDepends/ata)
+endef
+
+define KernelPackage/ata-octeon-cf/description
+ Octeon Compact Flash support.
+endef
+
+$(eval $(call KernelPackage,ata-octeon-cf))
+
+
+define KernelPackage/usb-octeon
+ SUBMENU:=$(USB_MENU)
+ TITLE:=Support for the Octeon USB OTG controller
+ DEPENDS:=@TARGET_octeon
+ KCONFIG:=CONFIG_USB_DWC_OTG
+ FILES:=$(LINUX_DIR)/drivers/usb/host/dwc_otg/dwc_otg.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,50,dwc_otg)
+ $(call AddDepends/usb)
+endef
+
+define KernelPackage/usb-octeon/description
+ Kernel support for the Octeon USB host controller
+endef
+
+$(eval $(call KernelPackage,usb-octeon))