summaryrefslogtreecommitdiffstats
path: root/target/linux/octeon
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-08-23 17:31:04 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-08-23 17:31:04 +0000
commit043edd80744308e9d1b8c0bf2213bd7a71770cb1 (patch)
tree8b1ccfd0ecdc4680df553aae16f6f937193a5b4c /target/linux/octeon
parent6f232cba6241c248000fbca5e7261c1a79accbb4 (diff)
downloadmaster-31e0f0ae-043edd80744308e9d1b8c0bf2213bd7a71770cb1.tar.gz
master-31e0f0ae-043edd80744308e9d1b8c0bf2213bd7a71770cb1.tar.bz2
master-31e0f0ae-043edd80744308e9d1b8c0bf2213bd7a71770cb1.zip
kernel: update 3.10 to 3.10.9
Also refresh 3.10 patches. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 37832
Diffstat (limited to 'target/linux/octeon')
-rw-r--r--target/linux/octeon/Makefile2
-rw-r--r--target/linux/octeon/patches-3.10/0001-MIPS-Octeon-Fix-DT-pruning-bug-with-pip-ports.patch7
-rw-r--r--target/linux/octeon/patches-3.10/0002-MIPS-Octeon-Enable-interfaces-on-EdgeRouter-Lite.patch13
-rw-r--r--target/linux/octeon/patches-3.10/0003-staging-MIPS-add-Octeon-USB-HCD-support.patch4
-rw-r--r--target/linux/octeon/patches-3.10/0004-fix_hcd.patch14
5 files changed, 11 insertions, 29 deletions
diff --git a/target/linux/octeon/Makefile b/target/linux/octeon/Makefile
index ea005d01f6..903e83a963 100644
--- a/target/linux/octeon/Makefile
+++ b/target/linux/octeon/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 pci usb
CFLAGS:=-Os -pipe -march=octeon -fno-caller-saves
MAINTAINER:=John Crispin <blogic@openwrt.org>
-LINUX_VERSION:=3.10
+LINUX_VERSION:=3.10.9
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/octeon/patches-3.10/0001-MIPS-Octeon-Fix-DT-pruning-bug-with-pip-ports.patch b/target/linux/octeon/patches-3.10/0001-MIPS-Octeon-Fix-DT-pruning-bug-with-pip-ports.patch
index 6f1270020e..0a905d5c38 100644
--- a/target/linux/octeon/patches-3.10/0001-MIPS-Octeon-Fix-DT-pruning-bug-with-pip-ports.patch
+++ b/target/linux/octeon/patches-3.10/0001-MIPS-Octeon-Fix-DT-pruning-bug-with-pip-ports.patch
@@ -24,11 +24,9 @@ Signed-off-by: Ralf Baechle <ralf@linux-mips.org>
arch/mips/cavium-octeon/octeon-platform.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
-diff --git a/arch/mips/cavium-octeon/octeon-platform.c b/arch/mips/cavium-octeon/octeon-platform.c
-index 7b746e7..1830874 100644
--- a/arch/mips/cavium-octeon/octeon-platform.c
+++ b/arch/mips/cavium-octeon/octeon-platform.c
-@@ -334,9 +334,10 @@ static void __init octeon_fdt_pip_iface(int pip, int idx, u64 *pmac)
+@@ -334,9 +334,10 @@ static void __init octeon_fdt_pip_iface(
char name_buffer[20];
int iface;
int p;
@@ -41,6 +39,3 @@ index 7b746e7..1830874 100644
snprintf(name_buffer, sizeof(name_buffer), "interface@%d", idx);
iface = fdt_subnode_offset(initial_boot_params, pip, name_buffer);
---
-1.7.10.4
-
diff --git a/target/linux/octeon/patches-3.10/0002-MIPS-Octeon-Enable-interfaces-on-EdgeRouter-Lite.patch b/target/linux/octeon/patches-3.10/0002-MIPS-Octeon-Enable-interfaces-on-EdgeRouter-Lite.patch
index 030d1e2db1..84b66006af 100644
--- a/target/linux/octeon/patches-3.10/0002-MIPS-Octeon-Enable-interfaces-on-EdgeRouter-Lite.patch
+++ b/target/linux/octeon/patches-3.10/0002-MIPS-Octeon-Enable-interfaces-on-EdgeRouter-Lite.patch
@@ -19,11 +19,9 @@ Signed-off-by: Ralf Baechle <ralf@linux-mips.org>
arch/mips/include/asm/octeon/cvmx-bootinfo.h | 2 ++
2 files changed, 15 insertions(+)
-diff --git a/arch/mips/cavium-octeon/executive/cvmx-helper-board.c b/arch/mips/cavium-octeon/executive/cvmx-helper-board.c
-index 7c64977..0a1283c 100644
--- a/arch/mips/cavium-octeon/executive/cvmx-helper-board.c
+++ b/arch/mips/cavium-octeon/executive/cvmx-helper-board.c
-@@ -181,6 +181,11 @@ int cvmx_helper_board_get_mii_address(int ipd_port)
+@@ -181,6 +181,11 @@ int cvmx_helper_board_get_mii_address(in
return ipd_port - 16 + 4;
else
return -1;
@@ -35,7 +33,7 @@ index 7c64977..0a1283c 100644
}
/* Some unknown board. Somebody forgot to update this function... */
-@@ -706,6 +711,14 @@ int __cvmx_helper_board_hardware_enable(int interface)
+@@ -706,6 +711,14 @@ int __cvmx_helper_board_hardware_enable(
}
}
}
@@ -50,8 +48,6 @@ index 7c64977..0a1283c 100644
}
return 0;
}
-diff --git a/arch/mips/include/asm/octeon/cvmx-bootinfo.h b/arch/mips/include/asm/octeon/cvmx-bootinfo.h
-index 284fa8d..7b7818d 100644
--- a/arch/mips/include/asm/octeon/cvmx-bootinfo.h
+++ b/arch/mips/include/asm/octeon/cvmx-bootinfo.h
@@ -227,6 +227,7 @@ enum cvmx_board_types_enum {
@@ -62,7 +58,7 @@ index 284fa8d..7b7818d 100644
CVMX_BOARD_TYPE_CUST_PRIVATE_MAX = 30000,
/* The remaining range is reserved for future use. */
-@@ -325,6 +326,7 @@ static inline const char *cvmx_board_type_to_string(enum
+@@ -325,6 +326,7 @@ static inline const char *cvmx_board_typ
/* Customer private range */
ENUM_BRD_TYPE_CASE(CVMX_BOARD_TYPE_CUST_PRIVATE_MIN)
@@ -70,6 +66,3 @@ index 284fa8d..7b7818d 100644
ENUM_BRD_TYPE_CASE(CVMX_BOARD_TYPE_CUST_PRIVATE_MAX)
}
return "Unsupported Board";
---
-1.7.10.4
-
diff --git a/target/linux/octeon/patches-3.10/0003-staging-MIPS-add-Octeon-USB-HCD-support.patch b/target/linux/octeon/patches-3.10/0003-staging-MIPS-add-Octeon-USB-HCD-support.patch
index 260dc1b438..7f602585ca 100644
--- a/target/linux/octeon/patches-3.10/0003-staging-MIPS-add-Octeon-USB-HCD-support.patch
+++ b/target/linux/octeon/patches-3.10/0003-staging-MIPS-add-Octeon-USB-HCD-support.patch
@@ -60,8 +60,6 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
create mode 100644 drivers/staging/octeon-usb/cvmx-usbnx-defs.h
create mode 100644 drivers/staging/octeon-usb/octeon-hcd.c
-diff --git a/drivers/staging/Kconfig b/drivers/staging/Kconfig
-index 4464f26..f64b662 100644
--- a/drivers/staging/Kconfig
+++ b/drivers/staging/Kconfig
@@ -62,6 +62,8 @@ source "drivers/staging/line6/Kconfig"
@@ -73,8 +71,6 @@ index 4464f26..f64b662 100644
source "drivers/staging/serqt_usb2/Kconfig"
source "drivers/staging/vt6655/Kconfig"
-diff --git a/drivers/staging/Makefile b/drivers/staging/Makefile
-index f689b9d..1fb58a1 100644
--- a/drivers/staging/Makefile
+++ b/drivers/staging/Makefile
@@ -25,6 +25,7 @@ obj-$(CONFIG_LINE6_USB) += line6/
diff --git a/target/linux/octeon/patches-3.10/0004-fix_hcd.patch b/target/linux/octeon/patches-3.10/0004-fix_hcd.patch
index e8cadbfb02..318e59cb3e 100644
--- a/target/linux/octeon/patches-3.10/0004-fix_hcd.patch
+++ b/target/linux/octeon/patches-3.10/0004-fix_hcd.patch
@@ -1,8 +1,6 @@
-Index: linux-3.10/drivers/staging/octeon-usb/octeon-hcd.c
-===================================================================
---- linux-3.10.orig/drivers/staging/octeon-usb/octeon-hcd.c 2013-08-03 16:11:44.269610286 +0200
-+++ linux-3.10/drivers/staging/octeon-usb/octeon-hcd.c 2013-08-04 13:18:54.011421971 +0200
-@@ -673,8 +673,9 @@
+--- a/drivers/staging/octeon-usb/octeon-hcd.c
++++ b/drivers/staging/octeon-usb/octeon-hcd.c
+@@ -673,8 +673,9 @@ static const struct hc_driver octeon_hc_
};
@@ -13,7 +11,7 @@ Index: linux-3.10/drivers/staging/octeon-usb/octeon-hcd.c
int status;
int usb_num = to_platform_device(dev)->id;
int irq = platform_get_irq(to_platform_device(dev), 0);
-@@ -728,8 +729,9 @@
+@@ -728,8 +729,9 @@ static int octeon_usb_driver_probe(struc
return 0;
}
@@ -24,7 +22,7 @@ Index: linux-3.10/drivers/staging/octeon-usb/octeon-hcd.c
int status;
struct usb_hcd *hcd = dev_get_drvdata(dev);
struct octeon_hcd *priv = hcd_to_octeon(hcd);
-@@ -748,30 +750,35 @@
+@@ -748,30 +750,35 @@ static int octeon_usb_driver_remove(stru
return 0;
}
@@ -72,7 +70,7 @@ Index: linux-3.10/drivers/staging/octeon-usb/octeon-hcd.c
/*
* Only cn52XX and cn56XX have DWC_OTG USB hardware and the
* IOB priority registers. Under heavy network load USB
-@@ -792,37 +799,14 @@
+@@ -792,37 +799,14 @@ static int __init octeon_usb_module_init
cvmx_write_csr(CVMX_IOB_N2C_L2C_PRI_CNT, pri_cnt.u64);
}