summaryrefslogtreecommitdiffstats
path: root/target/linux/octeon
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2014-09-10 21:40:19 +0000
committerLuka Perkov <luka@openwrt.org>2014-09-10 21:40:19 +0000
commit02629d8f87303a03e3ac36f48c508242d9b8cb09 (patch)
tree250a83e0d0e2cf5c7fe49e0a2087f3739f4509c2 /target/linux/octeon
parent7be0ed78e7cf578aa89996d408703ea2ab79a1e8 (diff)
downloadmaster-31e0f0ae-02629d8f87303a03e3ac36f48c508242d9b8cb09.tar.gz
master-31e0f0ae-02629d8f87303a03e3ac36f48c508242d9b8cb09.tar.bz2
master-31e0f0ae-02629d8f87303a03e3ac36f48c508242d9b8cb09.zip
kernel: update 3.14 to 3.14.18
Targets were build tested and patches are refreshed. Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 42463
Diffstat (limited to 'target/linux/octeon')
-rw-r--r--target/linux/octeon/Makefile3
-rw-r--r--target/linux/octeon/patches-3.14/110-er200-ethernet_probe_order.patch10
-rw-r--r--target/linux/octeon/patches-3.14/120-octeon_platform_usb.patch10
3 files changed, 9 insertions, 14 deletions
diff --git a/target/linux/octeon/Makefile b/target/linux/octeon/Makefile
index 7b9163cdc4..507938fe7b 100644
--- a/target/linux/octeon/Makefile
+++ b/target/linux/octeon/Makefile
@@ -14,8 +14,7 @@ CPU_TYPE:=octeon
CPU_CFLAGS_octeon:=-march=octeon -mabi=64
MAINTAINER:=John Crispin <blogic@openwrt.org>
-LINUX_VERSION:=3.10.49
-LINUX_VERSION:=3.14.14
+LINUX_VERSION:=3.14.18
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/octeon/patches-3.14/110-er200-ethernet_probe_order.patch b/target/linux/octeon/patches-3.14/110-er200-ethernet_probe_order.patch
index 0670f616cd..1771fba517 100644
--- a/target/linux/octeon/patches-3.14/110-er200-ethernet_probe_order.patch
+++ b/target/linux/octeon/patches-3.14/110-er200-ethernet_probe_order.patch
@@ -1,8 +1,6 @@
-Index: linux-3.14.14/drivers/staging/octeon/ethernet.c
-===================================================================
---- linux-3.14.14.orig/drivers/staging/octeon/ethernet.c 2014-08-07 17:03:44.000000000 +0200
-+++ linux-3.14.14/drivers/staging/octeon/ethernet.c 2014-08-07 17:07:31.768932379 +0200
-@@ -624,6 +624,7 @@
+--- a/drivers/staging/octeon/ethernet.c
++++ b/drivers/staging/octeon/ethernet.c
+@@ -624,6 +624,7 @@ static int cvm_oct_probe(struct platform
int interface;
int fau = FAU_NUM_PACKET_BUFFERS_TO_FREE;
int qos;
@@ -10,7 +8,7 @@ Index: linux-3.14.14/drivers/staging/octeon/ethernet.c
struct device_node *pip;
octeon_mdiobus_force_mod_depencency();
-@@ -707,13 +708,19 @@
+@@ -707,13 +708,19 @@ static int cvm_oct_probe(struct platform
}
num_interfaces = cvmx_helper_get_number_of_interfaces();
diff --git a/target/linux/octeon/patches-3.14/120-octeon_platform_usb.patch b/target/linux/octeon/patches-3.14/120-octeon_platform_usb.patch
index 2137b4733e..7cffaf621f 100644
--- a/target/linux/octeon/patches-3.14/120-octeon_platform_usb.patch
+++ b/target/linux/octeon/patches-3.14/120-octeon_platform_usb.patch
@@ -1,8 +1,6 @@
-Index: linux-3.10.49/arch/mips/cavium-octeon/octeon-platform.c
-===================================================================
---- linux-3.10.49.orig/arch/mips/cavium-octeon/octeon-platform.c 2014-07-26 20:39:48.109010152 +0100
-+++ linux-3.10.49/arch/mips/cavium-octeon/octeon-platform.c 2014-07-26 20:41:10.005008627 +0100
-@@ -82,7 +82,7 @@
+--- a/arch/mips/cavium-octeon/octeon-platform.c
++++ b/arch/mips/cavium-octeon/octeon-platform.c
+@@ -82,7 +82,7 @@ static int __init octeon_ehci_device_ini
};
/* Only Octeon2 has ehci/ohci */
@@ -11,7 +9,7 @@ Index: linux-3.10.49/arch/mips/cavium-octeon/octeon-platform.c
return 0;
if (octeon_is_simulation() || usb_disabled())
-@@ -131,7 +131,7 @@
+@@ -131,7 +131,7 @@ static int __init octeon_ohci_device_ini
};
/* Only Octeon2 has ehci/ohci */