summaryrefslogtreecommitdiffstats
path: root/target/linux/mxs
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2014-08-08 13:38:22 +0000
committerLuka Perkov <luka@openwrt.org>2014-08-08 13:38:22 +0000
commitdd8d72909634e0ba521519748827cb06f8c3f37d (patch)
treef43bc5d2e2fc1a21ea27855f88182ed11c126405 /target/linux/mxs
parentc1d698fce45c485516b2358d78cc976e8515862c (diff)
downloadmaster-31e0f0ae-dd8d72909634e0ba521519748827cb06f8c3f37d.tar.gz
master-31e0f0ae-dd8d72909634e0ba521519748827cb06f8c3f37d.tar.bz2
master-31e0f0ae-dd8d72909634e0ba521519748827cb06f8c3f37d.zip
kernel: update 3.14 to 3.14.16
Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 42070
Diffstat (limited to 'target/linux/mxs')
-rw-r--r--target/linux/mxs/Makefile2
-rw-r--r--target/linux/mxs/patches-3.14/100-soc-audio-support.patch2
-rw-r--r--target/linux/mxs/patches-3.14/120-dt-add-i2c.patch6
-rw-r--r--target/linux/mxs/patches-3.14/130-mxs-mmc-fix-card-detect.patch11
-rw-r--r--target/linux/mxs/patches-3.14/200-duckbill.patch2
5 files changed, 9 insertions, 14 deletions
diff --git a/target/linux/mxs/Makefile b/target/linux/mxs/Makefile
index 1c68c99b30..c6cd0ce46a 100644
--- a/target/linux/mxs/Makefile
+++ b/target/linux/mxs/Makefile
@@ -13,7 +13,7 @@ FEATURES:=ext4 rtc usb gpio
CPU_TYPE:=arm926ej-s
MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
-LINUX_VERSION:=3.14.14
+LINUX_VERSION:=3.14.16
KERNELNAME:="zImage dtbs"
define Target/Description
diff --git a/target/linux/mxs/patches-3.14/100-soc-audio-support.patch b/target/linux/mxs/patches-3.14/100-soc-audio-support.patch
index f122f1b41c..7297458244 100644
--- a/target/linux/mxs/patches-3.14/100-soc-audio-support.patch
+++ b/target/linux/mxs/patches-3.14/100-soc-audio-support.patch
@@ -8,7 +8,7 @@
help
Normally ASoC codec drivers are only built if a machine driver which
uses them is also built since they are only usable with a machine
-@@ -534,6 +535,9 @@ config SND_SOC_WM9712
+@@ -536,6 +537,9 @@ config SND_SOC_WM9712
config SND_SOC_WM9713
tristate
diff --git a/target/linux/mxs/patches-3.14/120-dt-add-i2c.patch b/target/linux/mxs/patches-3.14/120-dt-add-i2c.patch
index 3f89fff706..50bd8666b4 100644
--- a/target/linux/mxs/patches-3.14/120-dt-add-i2c.patch
+++ b/target/linux/mxs/patches-3.14/120-dt-add-i2c.patch
@@ -40,7 +40,7 @@
auart0_pins_a: auart0@0 {
reg = <0>;
fsl,pinmux-ids = <
-@@ -443,7 +476,12 @@
+@@ -444,7 +477,12 @@
};
i2c@80058000 {
@@ -55,7 +55,7 @@
status = "disabled";
--- a/arch/arm/boot/dts/imx23-olinuxino.dts
+++ b/arch/arm/boot/dts/imx23-olinuxino.dts
-@@ -79,6 +79,12 @@
+@@ -73,6 +73,12 @@
status = "okay";
};
@@ -68,7 +68,7 @@
duart: serial@80070000 {
pinctrl-names = "default";
pinctrl-0 = <&duart_pins_a>;
-@@ -94,7 +100,7 @@
+@@ -88,7 +94,7 @@
usbphy0: usbphy@8007c000 {
status = "okay";
};
diff --git a/target/linux/mxs/patches-3.14/130-mxs-mmc-fix-card-detect.patch b/target/linux/mxs/patches-3.14/130-mxs-mmc-fix-card-detect.patch
index c9754b1603..1cfde83655 100644
--- a/target/linux/mxs/patches-3.14/130-mxs-mmc-fix-card-detect.patch
+++ b/target/linux/mxs/patches-3.14/130-mxs-mmc-fix-card-detect.patch
@@ -27,8 +27,6 @@ Signed-off-by: Chris Ball <chris@printf.net>
drivers/mmc/host/mxs-mmc.c | 7 +++++++
1 file changed, 7 insertions(+)
-diff --git a/drivers/mmc/host/mxs-mmc.c b/drivers/mmc/host/mxs-mmc.c
-index 073e871..babfea0 100644
--- a/drivers/mmc/host/mxs-mmc.c
+++ b/drivers/mmc/host/mxs-mmc.c
@@ -70,6 +70,7 @@ struct mxs_mmc_host {
@@ -39,7 +37,7 @@ index 073e871..babfea0 100644
};
static int mxs_mmc_get_cd(struct mmc_host *mmc)
-@@ -78,6 +79,9 @@ static int mxs_mmc_get_cd(struct mmc_host *mmc)
+@@ -78,6 +79,9 @@ static int mxs_mmc_get_cd(struct mmc_hos
struct mxs_ssp *ssp = &host->ssp;
int present, ret;
@@ -49,7 +47,7 @@ index 073e871..babfea0 100644
ret = mmc_gpio_get_cd(mmc);
if (ret >= 0)
return ret;
-@@ -568,6 +572,7 @@ static int mxs_mmc_probe(struct platform_device *pdev)
+@@ -568,6 +572,7 @@ static int mxs_mmc_probe(struct platform
{
const struct of_device_id *of_id =
of_match_device(mxs_mmc_dt_ids, &pdev->dev);
@@ -57,7 +55,7 @@ index 073e871..babfea0 100644
struct mxs_mmc_host *host;
struct mmc_host *mmc;
struct resource *iores;
-@@ -634,6 +639,8 @@ static int mxs_mmc_probe(struct platform_device *pdev)
+@@ -634,6 +639,8 @@ static int mxs_mmc_probe(struct platform
mmc->caps = MMC_CAP_SD_HIGHSPEED | MMC_CAP_MMC_HIGHSPEED |
MMC_CAP_SDIO_IRQ | MMC_CAP_NEEDS_POLL;
@@ -66,6 +64,3 @@ index 073e871..babfea0 100644
mmc->f_min = 400000;
mmc->f_max = 288000000;
---
-2.0.3
-
diff --git a/target/linux/mxs/patches-3.14/200-duckbill.patch b/target/linux/mxs/patches-3.14/200-duckbill.patch
index f4fda0261f..e92e762a12 100644
--- a/target/linux/mxs/patches-3.14/200-duckbill.patch
+++ b/target/linux/mxs/patches-3.14/200-duckbill.patch
@@ -1,6 +1,6 @@
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
-@@ -164,6 +164,7 @@ dtb-$(CONFIG_ARCH_MXS) += imx23-evk.dtb
+@@ -184,6 +184,7 @@ dtb-$(CONFIG_ARCH_MXS) += imx23-evk.dtb
imx28-cfa10057.dtb \
imx28-cfa10058.dtb \
imx28-evk.dtb \