summaryrefslogtreecommitdiffstats
path: root/target/linux/mxs
diff options
context:
space:
mode:
authorZoltan Herpai <wigyori@uid0.hu>2015-04-10 21:34:21 +0000
committerZoltan Herpai <wigyori@uid0.hu>2015-04-10 21:34:21 +0000
commitdb4ce3d16c608bdd80c09f5bc72c05b90b8ef8b5 (patch)
treed2713cf25d18d2ab1848c489b6ed5ba50fa4a7f7 /target/linux/mxs
parentbbad3f360e955403a0a38fb0919e52e7874476b9 (diff)
downloadmaster-31e0f0ae-db4ce3d16c608bdd80c09f5bc72c05b90b8ef8b5.tar.gz
master-31e0f0ae-db4ce3d16c608bdd80c09f5bc72c05b90b8ef8b5.tar.bz2
master-31e0f0ae-db4ce3d16c608bdd80c09f5bc72c05b90b8ef8b5.zip
mxs: Include the right kernel image in the rootfs
Signed-off-by: Harald Geyer <harald@ccbib.org> Acked-by: Michael Heimpold <mhei@heimpold.de> SVN-Revision: 45368
Diffstat (limited to 'target/linux/mxs')
-rw-r--r--target/linux/mxs/image/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/target/linux/mxs/image/Makefile b/target/linux/mxs/image/Makefile
index 55e88c25f3..9830a7d616 100644
--- a/target/linux/mxs/image/Makefile
+++ b/target/linux/mxs/image/Makefile
@@ -22,10 +22,15 @@ endef
define Image/InstallKernel
- ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_KERNEL),)
+ ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_ZIMAGE),)
mkdir -p $(TARGET_DIR)/boot
$(CP) $(LINUX_DIR)/arch/arm/boot/zImage $(TARGET_DIR)/boot/
endif
+
+ ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_UIMAGE),)
+ mkdir -p $(TARGET_DIR)/boot
+ cp $(KDIR)/uImage $(TARGET_DIR)/boot/
+ endif
ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_DTB),)
mkdir -p $(TARGET_DIR)/boot