summaryrefslogtreecommitdiffstats
path: root/target/linux/mxs
diff options
context:
space:
mode:
authorZoltan Herpai <wigyori@uid0.hu>2015-09-21 21:10:43 +0000
committerZoltan Herpai <wigyori@uid0.hu>2015-09-21 21:10:43 +0000
commitce59fe6b3d7ec186a12cf784038cc192a8eb9d4f (patch)
treed92a729e86a5f0d5b47dc8492ef721319e70bdaa /target/linux/mxs
parentac65377bf7089fa2844ba71722b8999e8e1e0ac7 (diff)
downloadmaster-31e0f0ae-ce59fe6b3d7ec186a12cf784038cc192a8eb9d4f.tar.gz
master-31e0f0ae-ce59fe6b3d7ec186a12cf784038cc192a8eb9d4f.tar.bz2
master-31e0f0ae-ce59fe6b3d7ec186a12cf784038cc192a8eb9d4f.zip
mxs: re-work SD card image generation
- Duckbill uses a different partitioning approach than standard FSL and Olimex - use new sdimage to integrate U-Boot into the SD card images Signed-off-by: Michael Heimpold <mhei@heimpold.de> SVN-Revision: 47021
Diffstat (limited to 'target/linux/mxs')
-rw-r--r--target/linux/mxs/image/Config.in9
-rw-r--r--target/linux/mxs/image/Makefile34
-rw-r--r--target/linux/mxs/image/gen_sdcard_ext4_ext4.sh33
-rw-r--r--[-rwxr-xr-x]target/linux/mxs/image/gen_sdcard_vfat_ext4.sh (renamed from target/linux/mxs/image/gen_mxs_sdcard_img.sh)17
4 files changed, 68 insertions, 25 deletions
diff --git a/target/linux/mxs/image/Config.in b/target/linux/mxs/image/Config.in
index b71edf7ccc..250553e356 100644
--- a/target/linux/mxs/image/Config.in
+++ b/target/linux/mxs/image/Config.in
@@ -1,5 +1,8 @@
-config MXS_SD_BOOT_PARTSIZE
+config TARGET_BOOTFS_PARTSIZE
int "Boot (SD Card) filesystem partition size (in MB)"
- depends on TARGET_mxs
+ depends on TARGET_mxs_olinuxino-maxi || TARGET_mxs_olinuxino-micro
default 8
-
+ help
+ On the Olimex OLinuXino boards, mainline U-Boot loads the
+ linux kernel and device tree file from a FAT partition.
+ The default value of 8 MB should be more than adequate.
diff --git a/target/linux/mxs/image/Makefile b/target/linux/mxs/image/Makefile
index 7e6a1a000c..94fed8215c 100644
--- a/target/linux/mxs/image/Makefile
+++ b/target/linux/mxs/image/Makefile
@@ -7,13 +7,13 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-include $(INCLUDE_DIR)/host.mk
BOARDS:= \
imx23-olinuxino \
imx28-duckbill
+
FAT32_BLOCK_SIZE=1024
-FAT32_BLOCKS=$(shell echo $$(($(CONFIG_MXS_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
+FAT32_BLOCKS=$(shell echo $$(($(CONFIG_TARGET_BOOTFS_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
define Image/BuildKernel
mkimage -A arm -O linux -T kernel -C none \
@@ -44,37 +44,45 @@ define Image/InstallKernel
endef
-define Image/Build/SDCard
+define Image/Build/SDCard-vfat-ext4
rm -f $(KDIR)/boot.img
mkdosfs $(KDIR)/boot.img -C $(FAT32_BLOCKS)
- mcopy -i $(KDIR)/boot.img $(DTS_DIR)/$(2).dtb ::$(2).dtb
+ mcopy -i $(KDIR)/boot.img $(DTS_DIR)/$(3).dtb ::$(3).dtb
mcopy -i $(KDIR)/boot.img $(BIN_DIR)/$(IMG_PREFIX)-uImage ::uImage
- ./gen_mxs_sdcard_img.sh \
- $(BIN_DIR)/$(IMG_PREFIX)-$(PROFILE)-sdcard-vfat-$(1).img \
+ ./gen_sdcard_vfat_ext4.sh \
+ $(BIN_DIR)/$(2) \
+ $(BIN_DIR)/uboot-mxs-$(4)/uboot-mxs-$(4).sb \
$(KDIR)/boot.img \
$(KDIR)/root.$(1) \
- $(CONFIG_MXS_SD_BOOT_PARTSIZE) \
- $(CONFIG_TARGET_ROOTFS_PARTSIZE) \
- $(BIN_DIR)/uboot-mxs-$(3)/uboot-mxs-$(3).sb
+ $(CONFIG_TARGET_BOOTFS_PARTSIZE) \
+ $(CONFIG_TARGET_ROOTFS_PARTSIZE)
+endef
+
+define Image/Build/SDCard-ext4-ext4
+ ./gen_sdcard_ext4_ext4.sh \
+ $(BIN_DIR)/$(2) \
+ $(BIN_DIR)/uboot-mxs-$(4)/uboot-mxs-$(4).sb \
+ $(KDIR)/root.$(1) \
+ $(CONFIG_TARGET_ROOTFS_PARTSIZE)
endef
define Image/Build/Profile/olinuxino-maxi
- $(call Image/Build/SDCard,$(1),imx23-olinuxino,mx23_olinuxino)
+ $(call Image/Build/SDCard-vfat-ext4,$(1),$(2),imx23-olinuxino,mx23_olinuxino)
endef
define Image/Build/Profile/olinuxino-micro
- $(call Image/Build/SDCard,$(1),imx23-olinuxino,mx23_olinuxino)
+ $(call Image/Build/SDCard-vfat-ext4,$(1),$(2),imx23-olinuxino,mx23_olinuxino)
endef
define Image/Build/Profile/duckbill
- $(call Image/Build/SDCard,$(1),imx28-duckbill,duckbill)
+ $(call Image/Build/SDCard-ext4-ext4,$(1),$(2),imx28-duckbill,duckbill)
endef
define Image/Build
$(call Image/Build/$(1),$(1))
- $(call Image/Build/Profile/$(PROFILE),$(1))
+ $(call Image/Build/Profile/$(PROFILE),$(1),$(IMG_PREFIX)-$(PROFILE)-sdcard.img)
dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
endef
diff --git a/target/linux/mxs/image/gen_sdcard_ext4_ext4.sh b/target/linux/mxs/image/gen_sdcard_ext4_ext4.sh
new file mode 100644
index 0000000000..5653ba892f
--- /dev/null
+++ b/target/linux/mxs/image/gen_sdcard_ext4_ext4.sh
@@ -0,0 +1,33 @@
+#!/usr/bin/env bash
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+set -x
+[ $# -eq 4 ] || {
+ echo "SYNTAX: $0 <file> <u-boot.sb image> <rootfs image> <rootfs size>"
+ exit 1
+}
+
+OUTPUT="$1"
+UBOOT="$2"
+ROOTFS="$3"
+ROOTFSSIZE="$4"
+
+head=4
+sect=63
+
+# set the Boot stream partition size to 1M
+set `ptgen -o $OUTPUT -h $head -s $sect -l 1024 -t 53 -p 1M -t 83 -p ${ROOTFSSIZE}M -t 83 -p ${ROOTFSSIZE}M`
+
+ROOTFS1OFFSET="$(($3 / 512))"
+ROOTFS1SIZE="$(($4 / 512))"
+ROOTFS2OFFSET="$(($5 / 512))"
+ROOTFS2SIZE="$(($6 / 512))"
+
+dd bs=512 if="$ROOTFS" of="$OUTPUT" seek="$ROOTFS1OFFSET" conv=notrunc
+dd bs=512 if="$ROOTFS" of="$OUTPUT" seek="$ROOTFS2OFFSET" conv=notrunc
+sdimage -d "$OUTPUT" -f "$UBOOT"
diff --git a/target/linux/mxs/image/gen_mxs_sdcard_img.sh b/target/linux/mxs/image/gen_sdcard_vfat_ext4.sh
index 7faa8d5de9..616639d237 100755..100644
--- a/target/linux/mxs/image/gen_mxs_sdcard_img.sh
+++ b/target/linux/mxs/image/gen_sdcard_vfat_ext4.sh
@@ -1,5 +1,4 @@
#!/usr/bin/env bash
-
#
# Copyright (C) 2015 OpenWrt.org
#
@@ -7,18 +6,18 @@
# See /LICENSE for more information.
#
-set -x
+set -x
[ $# -eq 6 ] || {
- echo "SYNTAX: $0 <file> <bootfs image> <rootfs image> <bootfs size> <rootfs size> <u-boot image>"
+ echo "SYNTAX: $0 <file> <u-boot.sb image> <bootfs image> <rootfs image> <bootfs size> <rootfs size>"
exit 1
}
OUTPUT="$1"
-BOOTFS="$2"
-ROOTFS="$3"
-BOOTFSSIZE="$4"
-ROOTFSSIZE="$5"
-UBOOT="$6"
+UBOOT="$2"
+BOOTFS="$3"
+ROOTFS="$4"
+BOOTFSSIZE="$5"
+ROOTFSSIZE="$6"
head=4
sect=63
@@ -33,6 +32,6 @@ BOOTSIZE="$(($4 / 512))"
ROOTFSOFFSET="$(($5 / 512))"
ROOTFSSIZE="$(($6 / 512))"
-dd bs=512 if="$UBOOT" of="$OUTPUT" seek="$UBOOTOFFSET" conv=notrunc
dd bs=512 if="$BOOTFS" of="$OUTPUT" seek="$BOOTOFFSET" conv=notrunc
dd bs=512 if="$ROOTFS" of="$OUTPUT" seek="$ROOTFSOFFSET" conv=notrunc
+sdimage -d "$OUTPUT" -f "$UBOOT"