summaryrefslogtreecommitdiffstats
path: root/target/linux/mxs
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-12-11 18:35:41 +0000
committerJohn Crispin <john@openwrt.org>2014-12-11 18:35:41 +0000
commit6d52fd203d11c715981d7aea817401ad234c2181 (patch)
tree39b75e4dc22f50ab5e7991071e84e2853c442a49 /target/linux/mxs
parented61e202a1d7185374a33ebe86a3d8c1640e47b3 (diff)
downloadmaster-31e0f0ae-6d52fd203d11c715981d7aea817401ad234c2181.tar.gz
master-31e0f0ae-6d52fd203d11c715981d7aea817401ad234c2181.tar.bz2
master-31e0f0ae-6d52fd203d11c715981d7aea817401ad234c2181.zip
kernel/modules: fix chipidea
it should needs to depend on imx and mxs also remove duplicate kmod definition from mxs target Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 43627
Diffstat (limited to 'target/linux/mxs')
-rw-r--r--target/linux/mxs/modules.mk18
1 files changed, 1 insertions, 17 deletions
diff --git a/target/linux/mxs/modules.mk b/target/linux/mxs/modules.mk
index 3f9c8f8334..10ea3d685f 100644
--- a/target/linux/mxs/modules.mk
+++ b/target/linux/mxs/modules.mk
@@ -33,22 +33,6 @@ endef
$(eval $(call KernelPackage,wdt-stmp3xxx))
-define KernelPackage/usb-chipidea-imx
- TITLE:=Support for ChipIdea controllers on Freescale i.MX SoCs
- DEPENDS:=+kmod-usb-chipidea @TARGET_mxs
- FILES:= \
- $(LINUX_DIR)/drivers/usb/chipidea/ci_hdrc_imx.ko \
- $(LINUX_DIR)/drivers/usb/chipidea/usbmisc_imx.ko
- AUTOLOAD:=$(call AutoLoad,52,usbmisc_imx ci_hdrc_imx,1)
- $(call AddDepends/usb)
-endef
-
-define KernelPackage/usb-chipidea-imx/description
- Kernel support for USB ChipIdea controllers on Freescale i.MX SoCs
-endef
-
-$(eval $(call KernelPackage,usb-chipidea-imx,1))
-
define KernelPackage/sound-soc-mxs
TITLE:=Freescale i.MX23/i.MX28 built-in SoC sound support
KCONFIG:= \
@@ -63,7 +47,7 @@ define KernelPackage/sound-soc-mxs
DEPENDS:=@TARGET_mxs +kmod-sound-soc-core
$(call AddDepends/sound)
endef
-
+
define KernelPackage/sound-soc-mxs/description
Kernel support for Freescale i.MX23/i.MX28 built-in SoC audio
endef