summaryrefslogtreecommitdiffstats
path: root/target/linux/mxs
diff options
context:
space:
mode:
authorZoltan Herpai <wigyori@uid0.hu>2015-04-10 21:36:33 +0000
committerZoltan Herpai <wigyori@uid0.hu>2015-04-10 21:36:33 +0000
commit4fd21b203e7c5f7d6a64e25db5463e1f321abf26 (patch)
treeb21c622b890ea13fe199b565454d44b85a0bdb52 /target/linux/mxs
parentdb4ce3d16c608bdd80c09f5bc72c05b90b8ef8b5 (diff)
downloadmaster-31e0f0ae-4fd21b203e7c5f7d6a64e25db5463e1f321abf26.tar.gz
master-31e0f0ae-4fd21b203e7c5f7d6a64e25db5463e1f321abf26.tar.bz2
master-31e0f0ae-4fd21b203e7c5f7d6a64e25db5463e1f321abf26.zip
mxs: reinstate rootfs image creation and dtb copy
Signed-off-by: Harald Geyer <harald@ccbib.org> Acked-by: Michael Heimpold <mhei@heimpold.de> SVN-Revision: 45369
Diffstat (limited to 'target/linux/mxs')
-rw-r--r--target/linux/mxs/image/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/linux/mxs/image/Makefile b/target/linux/mxs/image/Makefile
index 9830a7d616..b5a092e365 100644
--- a/target/linux/mxs/image/Makefile
+++ b/target/linux/mxs/image/Makefile
@@ -9,6 +9,9 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
include $(INCLUDE_DIR)/host.mk
+BOARDS:= \
+ imx23-olinuxino \
+ imx28-duckbill
FAT32_BLOCK_SIZE=1024
FAT32_BLOCKS=$(shell echo $$(($(CONFIG_MXS_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
@@ -72,6 +75,7 @@ endef
define Image/Build
$(call Image/Build/$(1),$(1))
$(call Image/Build/Profile/$(PROFILE),$(1))
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
endef
$(eval $(call BuildImage))