summaryrefslogtreecommitdiffstats
path: root/target/linux/mxs
diff options
context:
space:
mode:
authorZoltan Herpai <wigyori@uid0.hu>2015-03-26 23:34:43 +0000
committerZoltan Herpai <wigyori@uid0.hu>2015-03-26 23:34:43 +0000
commit01748fbce2869eb120c0e94f3c18f9d3d86956ad (patch)
tree734b24710b638f7ffe351bef4d0d465747ab8ded /target/linux/mxs
parent23b4bf65071a7350aef24e54e6361f18170a8444 (diff)
downloadmaster-31e0f0ae-01748fbce2869eb120c0e94f3c18f9d3d86956ad.tar.gz
master-31e0f0ae-01748fbce2869eb120c0e94f3c18f9d3d86956ad.tar.bz2
master-31e0f0ae-01748fbce2869eb120c0e94f3c18f9d3d86956ad.zip
mxs: add sdcard image builder
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu> SVN-Revision: 45052
Diffstat (limited to 'target/linux/mxs')
-rw-r--r--target/linux/mxs/image/Config.in5
-rw-r--r--target/linux/mxs/image/Makefile65
-rwxr-xr-xtarget/linux/mxs/image/gen_mxs_sdcard_img.sh38
3 files changed, 77 insertions, 31 deletions
diff --git a/target/linux/mxs/image/Config.in b/target/linux/mxs/image/Config.in
new file mode 100644
index 0000000000..b71edf7ccc
--- /dev/null
+++ b/target/linux/mxs/image/Config.in
@@ -0,0 +1,5 @@
+config MXS_SD_BOOT_PARTSIZE
+ int "Boot (SD Card) filesystem partition size (in MB)"
+ depends on TARGET_mxs
+ default 8
+
diff --git a/target/linux/mxs/image/Makefile b/target/linux/mxs/image/Makefile
index c29925f2d8..86f62d0c20 100644
--- a/target/linux/mxs/image/Makefile
+++ b/target/linux/mxs/image/Makefile
@@ -7,21 +7,12 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
+include $(INCLUDE_DIR)/host.mk
-BOARDS:= \
- imx23-olinuxino \
- imx28-duckbill
+FAT32_BLOCK_SIZE=1024
+FAT32_BLOCKS=$(shell echo $$(($(CONFIG_MXS_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
-define Image/BuildKernel/olinuxino-bootlet
- cat $(LINUX_DIR)/arch/arm/boot/zImage $(DTS_DIR)/imx23-olinuxino.dtb > $(STAGING_DIR)/zImage_dtb
- (cd $(STAGING_DIR); \
- $(STAGING_DIR)/../host/bin/elftosb -z -c ./linux_prebuilt.db -o linux.sb; \
- dd if=/dev/zero of=sd_mmc_bootstream.raw bs=512 count=4; \
- dd if=linux.sb of=$(BIN_DIR)/openwrt-imx23-sbImage ibs=512 seek=4; \
- )
-endef
-
-define Image/BuildKernel/mxs-uboot
+define Image/BuildKernel
mkimage -A arm -O linux -T kernel -C none \
-a 0x40008000 -e 0x40008000 \
-n 'ARM OpenWrt Linux-$(LINUX_VERSION)' \
@@ -29,22 +20,6 @@ define Image/BuildKernel/mxs-uboot
cp $(KDIR)/uImage $(BIN_DIR)/$(IMG_PREFIX)-uImage
endef
-define Image/BuildKernel
-
- ifeq ($(CONFIG_PACKAGE_imx-bootlets),y)
- $(call Image/BuildKernel/olinuxino-bootlet)
- endif
-
- ifeq ($(CONFIG_PACKAGE_uboot-mxs-mx23_olinuxino),y)
- $(call Image/BuildKernel/mxs-uboot)
- endif
-
- $(CP) $(LINUX_DIR)/arch/arm/boot/zImage $(BIN_DIR)/openwrt-$(BOARD)-zImage
- $(foreach board,$(BOARDS),
- $(CP) $(DTS_DIR)/$(board).dtb $(BIN_DIR)/
- )
-endef
-
define Image/InstallKernel
ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_KERNEL),)
@@ -61,9 +36,37 @@ define Image/InstallKernel
endef
+define Image/Build/SDCard
+ rm -f $(KDIR)/boot.img
+ mkdosfs $(KDIR)/boot.img -C $(FAT32_BLOCKS)
+
+ mcopy -i $(KDIR)/boot.img $(BIN_DIR)/$(2).dtb ::$(2).dtb
+ mcopy -i $(KDIR)/boot.img $(BIN_DIR)/$(IMG_PREFIX)-uImage ::uImage
+
+ ./gen_mxs_sdcard_img.sh \
+ $(BIN_DIR)/$(IMG_PREFIX)-$(PROFILE)-sdcard-vfat-$(1).img \
+ $(KDIR)/boot.img \
+ $(KDIR)/root.$(1) \
+ $(CONFIG_MXS_SD_BOOT_PARTSIZE) \
+ $(CONFIG_TARGET_ROOTFS_PARTSIZE) \
+ $(BIN_DIR)/uboot-mxs-$(3).sb
+endef
+
+define Image/Build/Profile/olinuxino-maxi
+ $(call Image/Build/SDCard,$(1),imx23-olinuxino,mx23_olinuxino)
+endef
+
+define Image/Build/Profile/olinuxino-micro
+ $(call Image/Build/SDCard,$(1),imx23-olinuxino,mx23_olinuxino)
+endef
+
+define Image/Build/Profile/duckbill
+ $(call Image/Build/SDCard,$(1),imx28-duckbill,duckbill)
+endef
+
define Image/Build
- $(call Image/Build/$(1))
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
+ $(call Image/Build/$(1),$(1))
+ $(call Image/Build/Profile/$(PROFILE),$(1))
endef
$(eval $(call BuildImage))
diff --git a/target/linux/mxs/image/gen_mxs_sdcard_img.sh b/target/linux/mxs/image/gen_mxs_sdcard_img.sh
new file mode 100755
index 0000000000..7faa8d5de9
--- /dev/null
+++ b/target/linux/mxs/image/gen_mxs_sdcard_img.sh
@@ -0,0 +1,38 @@
+#!/usr/bin/env bash
+
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+set -x
+[ $# -eq 6 ] || {
+ echo "SYNTAX: $0 <file> <bootfs image> <rootfs image> <bootfs size> <rootfs size> <u-boot image>"
+ exit 1
+}
+
+OUTPUT="$1"
+BOOTFS="$2"
+ROOTFS="$3"
+BOOTFSSIZE="$4"
+ROOTFSSIZE="$5"
+UBOOT="$6"
+
+head=4
+sect=63
+
+# Set the u-boot storage to 2M
+set `ptgen -o $OUTPUT -h $head -s $sect -l 1024 -t 53 -p 2M -t c -p ${BOOTFSSIZE}M -t 83 -p ${ROOTFSSIZE}M`
+
+UBOOTOFFSET="$(($1 / 512))"
+UBOOTSIZE="$(($2 / 512))"
+BOOTOFFSET="$(($3 / 512))"
+BOOTSIZE="$(($4 / 512))"
+ROOTFSOFFSET="$(($5 / 512))"
+ROOTFSSIZE="$(($6 / 512))"
+
+dd bs=512 if="$UBOOT" of="$OUTPUT" seek="$UBOOTOFFSET" conv=notrunc
+dd bs=512 if="$BOOTFS" of="$OUTPUT" seek="$BOOTOFFSET" conv=notrunc
+dd bs=512 if="$ROOTFS" of="$OUTPUT" seek="$ROOTFSOFFSET" conv=notrunc