summaryrefslogtreecommitdiffstats
path: root/target/linux/mxs/profiles
diff options
context:
space:
mode:
authorZoltan Herpai <wigyori@uid0.hu>2013-10-14 21:22:40 +0000
committerZoltan Herpai <wigyori@uid0.hu>2013-10-14 21:22:40 +0000
commit9e2b69139b569a0e521685b0459fdda47121a93e (patch)
tree14a991a7dcc6ecda0e60d905ee7f47ad919f0ff9 /target/linux/mxs/profiles
parentbea9d64f4a79561a3644edbf2e6f5c493dfe3b31 (diff)
downloadmaster-31e0f0ae-9e2b69139b569a0e521685b0459fdda47121a93e.tar.gz
master-31e0f0ae-9e2b69139b569a0e521685b0459fdda47121a93e.tar.bz2
master-31e0f0ae-9e2b69139b569a0e521685b0459fdda47121a93e.zip
mxs: add support for I2SE Duckbill devices
Signed-off-by: Michael Heimpold <mhei@heimpold.de> Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu> SVN-Revision: 38407
Diffstat (limited to 'target/linux/mxs/profiles')
-rw-r--r--target/linux/mxs/profiles/02-duckbill.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/mxs/profiles/02-duckbill.mk b/target/linux/mxs/profiles/02-duckbill.mk
new file mode 100644
index 0000000000..847460ac31
--- /dev/null
+++ b/target/linux/mxs/profiles/02-duckbill.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/duckbill
+ NAME:=I2SE Duckbill series
+ DEPENDS:=+@TARGET_ROOTFS_INCLUDE_KERNEL +@TARGET_ROOTFS_INCLUDE_DTB
+ PACKAGES+= \
+ -dnsmasq -firewall -ppp -ip6tables -iptables -6relayd -mtd uboot-envtools \
+ kmod-leds-gpio kmod-ledtrig-timer kmod-usb-mxs-phy -kmod-ipt-nathelper
+endef
+
+define Profile/duckbill/Description
+ I2SE's Duckbill devices
+endef
+
+$(eval $(call Profile,duckbill))