summaryrefslogtreecommitdiffstats
path: root/target/linux/mxs/image
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-07-21 18:42:06 +0000
committerJohn Crispin <john@openwrt.org>2014-07-21 18:42:06 +0000
commit7d8f187201d361e1c0059d18d7e0f119ae4b6472 (patch)
treef0a41bad94859b216a0617a54dcc955cecd816d8 /target/linux/mxs/image
parent941dab02d52dd27bad0ad2aa3c80619996309d2a (diff)
downloadmaster-31e0f0ae-7d8f187201d361e1c0059d18d7e0f119ae4b6472.tar.gz
master-31e0f0ae-7d8f187201d361e1c0059d18d7e0f119ae4b6472.tar.bz2
master-31e0f0ae-7d8f187201d361e1c0059d18d7e0f119ae4b6472.zip
target/linux/*/image/Makefile: use new dts path variable
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 41791
Diffstat (limited to 'target/linux/mxs/image')
-rw-r--r--target/linux/mxs/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/mxs/image/Makefile b/target/linux/mxs/image/Makefile
index 59a89e9d50..c29925f2d8 100644
--- a/target/linux/mxs/image/Makefile
+++ b/target/linux/mxs/image/Makefile
@@ -13,7 +13,7 @@ BOARDS:= \
imx28-duckbill
define Image/BuildKernel/olinuxino-bootlet
- cat $(LINUX_DIR)/arch/arm/boot/zImage $(LINUX_DIR)/arch/arm/boot/dts/imx23-olinuxino.dtb > $(STAGING_DIR)/zImage_dtb
+ cat $(LINUX_DIR)/arch/arm/boot/zImage $(DTS_DIR)/imx23-olinuxino.dtb > $(STAGING_DIR)/zImage_dtb
(cd $(STAGING_DIR); \
$(STAGING_DIR)/../host/bin/elftosb -z -c ./linux_prebuilt.db -o linux.sb; \
dd if=/dev/zero of=sd_mmc_bootstream.raw bs=512 count=4; \
@@ -41,7 +41,7 @@ define Image/BuildKernel
$(CP) $(LINUX_DIR)/arch/arm/boot/zImage $(BIN_DIR)/openwrt-$(BOARD)-zImage
$(foreach board,$(BOARDS),
- $(CP) $(LINUX_DIR)/arch/arm/boot/dts/$(board).dtb $(BIN_DIR)/
+ $(CP) $(DTS_DIR)/$(board).dtb $(BIN_DIR)/
)
endef
@@ -55,7 +55,7 @@ define Image/InstallKernel
ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_DTB),)
mkdir -p $(TARGET_DIR)/boot
$(foreach board,$(BOARDS),
- $(CP) $(LINUX_DIR)/arch/arm/boot/dts/$(board).dtb $(TARGET_DIR)/boot/
+ $(CP) $(DTS_DIR)/$(board).dtb $(TARGET_DIR)/boot/
)
endif