summaryrefslogtreecommitdiffstats
path: root/target/linux/mxs/image
diff options
context:
space:
mode:
authorZoltan Herpai <wigyori@uid0.hu>2013-11-20 10:23:49 +0000
committerZoltan Herpai <wigyori@uid0.hu>2013-11-20 10:23:49 +0000
commit2bc70cfbace7d696ae37215e7895d4572d2b3f4d (patch)
tree3d9405918e557f282945493783047fae1757e760 /target/linux/mxs/image
parent17089f3f37820521f97afe0ac06635bd3ec533fe (diff)
downloadmaster-31e0f0ae-2bc70cfbace7d696ae37215e7895d4572d2b3f4d.tar.gz
master-31e0f0ae-2bc70cfbace7d696ae37215e7895d4572d2b3f4d.tar.bz2
master-31e0f0ae-2bc70cfbace7d696ae37215e7895d4572d2b3f4d.zip
mxs: build/profile-related changes - change uImage creation to use zImage - update image Makefile for further boards with u-boot support - add profile for OLinuXino Micro/Nano boards
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu> SVN-Revision: 38876
Diffstat (limited to 'target/linux/mxs/image')
-rw-r--r--target/linux/mxs/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/mxs/image/Makefile b/target/linux/mxs/image/Makefile
index 7c5c33168c..59a89e9d50 100644
--- a/target/linux/mxs/image/Makefile
+++ b/target/linux/mxs/image/Makefile
@@ -21,11 +21,11 @@ define Image/BuildKernel/olinuxino-bootlet
)
endef
-define Image/BuildKernel/olinuxino-uboot
+define Image/BuildKernel/mxs-uboot
mkimage -A arm -O linux -T kernel -C none \
-a 0x40008000 -e 0x40008000 \
-n 'ARM OpenWrt Linux-$(LINUX_VERSION)' \
- -d $(KDIR)/vmlinux $(KDIR)/uImage
+ -d $(KDIR)/zImage $(KDIR)/uImage
cp $(KDIR)/uImage $(BIN_DIR)/$(IMG_PREFIX)-uImage
endef
@@ -36,7 +36,7 @@ define Image/BuildKernel
endif
ifeq ($(CONFIG_PACKAGE_uboot-mxs-mx23_olinuxino),y)
- $(call Image/BuildKernel/olinuxino-uboot)
+ $(call Image/BuildKernel/mxs-uboot)
endif
$(CP) $(LINUX_DIR)/arch/arm/boot/zImage $(BIN_DIR)/openwrt-$(BOARD)-zImage