summaryrefslogtreecommitdiffstats
path: root/target/linux/mxs/Makefile
diff options
context:
space:
mode:
authorZoltan Herpai <wigyori@uid0.hu>2013-10-14 19:01:23 +0000
committerZoltan Herpai <wigyori@uid0.hu>2013-10-14 19:01:23 +0000
commit07043a853a34292a12044ab524d301ab5932315f (patch)
tree8feab1a6446b1621759f8eb2d7618af7d037ca8e /target/linux/mxs/Makefile
parent156ea733d4e88fb47b8b3582c1775a854d57c366 (diff)
downloadmaster-31e0f0ae-07043a853a34292a12044ab524d301ab5932315f.tar.gz
master-31e0f0ae-07043a853a34292a12044ab524d301ab5932315f.tar.bz2
master-31e0f0ae-07043a853a34292a12044ab524d301ab5932315f.zip
imx23: rename imx23 to mxs for upcoming imx23/28 support
Signed-off-by: Michael Heimpold <mhei@heimpold.de> Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu> SVN-Revision: 38394
Diffstat (limited to 'target/linux/mxs/Makefile')
-rw-r--r--target/linux/mxs/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/mxs/Makefile b/target/linux/mxs/Makefile
new file mode 100644
index 0000000000..fe08898fd3
--- /dev/null
+++ b/target/linux/mxs/Makefile
@@ -0,0 +1,27 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=mxs
+BOARDNAME:=Freescale i.MX23/i.MX28 series
+FEATURES:=ext4 rtc usb gpio
+CPU_TYPE:=arm926ej-s
+
+MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
+LINUX_VERSION:=3.10.15
+KERNELNAME:="zImage dtbs"
+
+define Target/Description
+ Support for Freescale i.MX23/i.MX28 boards
+endef
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += kmod-wdt-stmp3xxx
+
+$(eval $(call BuildTarget))