summaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2016-09-11 19:05:20 +0200
committerMathias Kresin <dev@kresin.me>2016-09-13 19:36:41 +0200
commit61c2a7339a70b34cc357f9f190921365c39073f9 (patch)
tree147d330471abdc1c7908ab37608ca547bcca93f1 /target/linux/mvebu
parent14b40d61e13ce0408d5ed9dff2ad3a18ab0c2471 (diff)
downloadmaster-31e0f0ae-61c2a7339a70b34cc357f9f190921365c39073f9.tar.gz
master-31e0f0ae-61c2a7339a70b34cc357f9f190921365c39073f9.tar.bz2
master-31e0f0ae-61c2a7339a70b34cc357f9f190921365c39073f9.zip
image: remove padding parameter from append-kernel/append-rootfs
Using pad-to instead of passing the optional padding to append-kernel or append-rootfs. It could be that the value of a variable is passed. In case the variable is empty no error is thrown. Furthermore the purpose of the extra parameter is hard to get without reading the code. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/mvebu')
-rw-r--r--target/linux/mvebu/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 2c3d6589fe..9509c1902f 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -71,7 +71,7 @@ define Device/UBI-factory
$(Device/UBI)
UBINIZE_OPTS := -E 5
IMAGES += factory.img
- IMAGE/factory.img := append-kernel $$$$(KERNEL_SIZE) | append-ubi | pad-to $$$$(PAGESIZE)
+ IMAGE/factory.img := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | pad-to $$$$(PAGESIZE)
endef
define Device/NAND-128K
@@ -167,7 +167,7 @@ TARGET_DEVICES += armada-370-db armada-370-rd armada-xp-db armada-xp-gp
define Device/armada-388-rd
DEVICE_TITLE := Marvell Armada 388 RD (RD-88F6820-AP)
IMAGES := firmware.bin
- IMAGE/firmware.bin := append-kernel 256k | append-rootfs | pad-rootfs
+ IMAGE/firmware.bin := append-kernel | pad-to 256k | append-rootfs | pad-rootfs
endef
TARGET_DEVICES += armada-388-rd