summaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-04-13 12:06:56 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-04-13 12:06:56 +0000
commit96c793f529105a80953a586568efbe0142ea7625 (patch)
treeb61d4abd5a2e37196ee1adc7d7b7afc6e51c2a31 /target/linux/mvebu
parent4da8f96754875c257e76cd50220978c181bd6f20 (diff)
downloadmaster-31e0f0ae-96c793f529105a80953a586568efbe0142ea7625.tar.gz
master-31e0f0ae-96c793f529105a80953a586568efbe0142ea7625.tar.bz2
master-31e0f0ae-96c793f529105a80953a586568efbe0142ea7625.zip
mvebu: generate a single firmware for the 385-db-ap
This has been done without having a board, but should work. Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 45412
Diffstat (limited to 'target/linux/mvebu')
-rw-r--r--target/linux/mvebu/image/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 443110113c..191dc27a00 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -154,6 +154,15 @@ define Image/Build/Profile/Mamba/squashfs
) > $(BIN_DIR)/$(IMG_PREFIX)-armada-xp-linksys-mamba-squashfs-factory.img
endef
+define Image/Build/Profile/385-DB-AP/squashfs
+ $(call Image/Build/UbinizeImage,armada-385-db-ap,,squashfs, -p 256KiB -m 4096)
+ ( \
+ dd if=$(KDIR)/uImage-armada-385-db-ap bs=8M conv=sync; \
+ dd if=$(KDIR)/$(IMG_PREFIX)-armada-385-db-ap-squashfs-ubinized.bin \
+ bs=4096 conv=sync; \
+ ) > $(BIN_DIR)/$(IMG_PREFIX)-armada-385-db-ap-squashfs-factory.img
+endef
+
# The Default profile should build everything
$(eval $(call MultiProfile,Default,$(PROFILES_LIST)))