summaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/profiles
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-02-06 11:16:20 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-02-06 11:16:20 +0000
commiteda08dd423ebd3160c7d5e928873fc98c4a028de (patch)
tree29f0ac015344f293c33c086f2348a7b169425054 /target/linux/mvebu/profiles
parent74338a700a09322575ada75a2edc05a9f896ef96 (diff)
downloadmaster-31e0f0ae-eda08dd423ebd3160c7d5e928873fc98c4a028de.tar.gz
master-31e0f0ae-eda08dd423ebd3160c7d5e928873fc98c4a028de.tar.bz2
master-31e0f0ae-eda08dd423ebd3160c7d5e928873fc98c4a028de.zip
mvebu: support building images for a single board
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 44290
Diffstat (limited to 'target/linux/mvebu/profiles')
-rw-r--r--target/linux/mvebu/profiles/000-Default.mk25
-rw-r--r--target/linux/mvebu/profiles/200-Evalboards.mk21
-rw-r--r--target/linux/mvebu/profiles/globalscale.mk21
-rw-r--r--target/linux/mvebu/profiles/linksys.mk (renamed from target/linux/mvebu/profiles/100-Generic.mk)10
-rw-r--r--target/linux/mvebu/profiles/marvell.mk95
-rw-r--r--target/linux/mvebu/profiles/plathome.mk21
6 files changed, 167 insertions, 26 deletions
diff --git a/target/linux/mvebu/profiles/000-Default.mk b/target/linux/mvebu/profiles/000-Default.mk
new file mode 100644
index 0000000000..981855fa3c
--- /dev/null
+++ b/target/linux/mvebu/profiles/000-Default.mk
@@ -0,0 +1,25 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+ NAME:=Default Profile (all drivers)
+ PACKAGES:= \
+ kmod-mmc kmod-mvsdio swconfig \
+ kmod-usb2 kmod-usb3 kmod-usb-storage \
+ kmod-of-i2c kmod-i2c-core kmod-i2c-mv64xxx \
+ kmod-ata-core kmod-ata-marvell-sata \
+ kmod-rtc-marvell kmod-thermal-armada \
+ kmod-gpio-button-hotplug kmod-hwmon-tmp421 \
+ kmod-hwmon-pwmfan kmod-leds-tlc59116 \
+ kmod-ledtrig-usbdev kmod-mwlwifi wpad-mini
+endef
+
+define Profile/Default/Description
+ Default package set compatible with most boards.
+endef
+
+$(eval $(call Profile,Default))
diff --git a/target/linux/mvebu/profiles/200-Evalboards.mk b/target/linux/mvebu/profiles/200-Evalboards.mk
deleted file mode 100644
index 52d0b9803d..0000000000
--- a/target/linux/mvebu/profiles/200-Evalboards.mk
+++ /dev/null
@@ -1,21 +0,0 @@
-#
-# Copyright (C) 2013-2014 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Evalboards
- NAME:=Evaluation / Development boards
- PACKAGES:= \
- kmod-mmc kmod-mvsdio kmod-usb2 kmod-usb-storage \
- kmod-of-i2c kmod-i2c-core kmod-i2c-mv64xxx \
- kmod-ata-core kmod-ata-marvell-sata \
- kmod-rtc-marvell kmod-thermal-armada
-endef
-
-define Profile/Evalboards/Description
- Package set compatible with most Marvell Armada 370/XP development based boards.
-endef
-
-$(eval $(call Profile,Evalboards))
diff --git a/target/linux/mvebu/profiles/globalscale.mk b/target/linux/mvebu/profiles/globalscale.mk
new file mode 100644
index 0000000000..45070db9f2
--- /dev/null
+++ b/target/linux/mvebu/profiles/globalscale.mk
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Mirabox
+ NAME:=Globalscale Mirabox
+ PACKAGES:= \
+ kmod-usb3 kmod-usb-storage \
+ kmod-of-i2c kmod-i2c-core kmod-i2c-mv64xxx \
+ kmod-rtc-marvell kmod-thermal-armada \
+ kmod-gpio-button-hotplug kmod-mmc kmod-mvsdio
+endef
+
+define Profile/Mirabox/Description
+ Package set compatible with the Globalscale Mirabox.
+endef
+
+$(eval $(call Profile,Mirabox))
diff --git a/target/linux/mvebu/profiles/100-Generic.mk b/target/linux/mvebu/profiles/linksys.mk
index 99d2d305d1..27437e9660 100644
--- a/target/linux/mvebu/profiles/100-Generic.mk
+++ b/target/linux/mvebu/profiles/linksys.mk
@@ -5,8 +5,8 @@
# See /LICENSE for more information.
#
-define Profile/Generic
- NAME:=Generic (default)
+define Profile/Mamba
+ NAME:=Linksys WRT1900AC (Mamba)
PACKAGES:= \
kmod-usb2 kmod-usb3 kmod-usb-storage \
kmod-of-i2c kmod-i2c-core kmod-i2c-mv64xxx \
@@ -18,8 +18,8 @@ define Profile/Generic
swconfig
endef
-define Profile/Generic/Description
- Package set compatible with most supported Marvell Armada 370/XP based boards.
+define Profile/Mamba/Description
+ Package set compatible with the Linksys WRT1900AC (Mamba).
endef
-$(eval $(call Profile,Generic))
+$(eval $(call Profile,Mamba))
diff --git a/target/linux/mvebu/profiles/marvell.mk b/target/linux/mvebu/profiles/marvell.mk
new file mode 100644
index 0000000000..875c55e158
--- /dev/null
+++ b/target/linux/mvebu/profiles/marvell.mk
@@ -0,0 +1,95 @@
+#
+# Copyright (C) 2013-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/370-DB
+ NAME:=Marvell Armada 370 DB (DB-88F6710-BP-DDR3)
+ PACKAGES:= \
+ kmod-mmc kmod-mvsdio kmod-usb2 kmod-usb-storage \
+ kmod-of-i2c kmod-i2c-core kmod-i2c-mv64xxx \
+ kmod-ata-core kmod-ata-marvell-sata \
+ kmod-rtc-marvell kmod-thermal-armada
+endef
+
+define Profile/370-DB/Description
+ Package set compatible with the Armada 370 evaluation board (DB-88F6710-BP-DDR3).
+endef
+
+$(eval $(call Profile,370-DB))
+
+define Profile/370-RD
+ NAME:=Marvell Armada 370 RD (RD-88F6710-A1)
+ PACKAGES:= \
+ kmod-mmc kmod-mvsdio kmod-usb2 kmod-usb-storage \
+ kmod-of-i2c kmod-i2c-core kmod-i2c-mv64xxx \
+ kmod-ata-core kmod-ata-marvell-sata \
+ kmod-rtc-marvell kmod-thermal-armada
+endef
+
+define Profile/370-RD/Description
+ Package set compatible with the Armada 370 reference design board (RD-88F6710-A1).
+endef
+
+$(eval $(call Profile,385-RD))
+
+define Profile/385-RD
+ NAME:=Marvell Armada 385 RD (RD-88F6820-AP)
+ PACKAGES:= \
+ kmod-mmc kmod-mvsdio kmod-usb3 kmod-usb-storage \
+ kmod-of-i2c kmod-i2c-core kmod-i2c-mv64xxx \
+ kmod-thermal-armada
+endef
+
+define Profile/385-RD/Description
+ Package set compatible with the Armada 385 reference design board (RD-88F6820-AP).
+endef
+
+$(eval $(call Profile,385-RD))
+
+define Profile/385-DB-AP
+ NAME:=Marvell Armada 385 DB AP (DB-88F6820-AP)
+ PACKAGES:= \
+ kmod-usb3 kmod-usb-storage \
+ kmod-of-i2c kmod-i2c-core kmod-i2c-mv64xxx \
+ kmod-ata-core kmod-ata-marvell-sata \
+ kmod-thermal-armada
+endef
+
+define Profile/385-DB-AP/Description
+ Package set compatible with the Armada 385 access point development board (DB-88F6820-AP).
+endef
+
+$(eval $(call Profile,385-DB-AP))
+
+define Profile/XP-DB
+ NAME:=Marvell Armada XP DB (DB-78460-BP)
+ PACKAGES:= \
+ kmod-mmc kmod-mvsdio kmod-usb2 kmod-usb-storage \
+ kmod-of-i2c kmod-i2c-core kmod-i2c-mv64xxx \
+ kmod-ata-core kmod-ata-marvell-sata \
+ kmod-rtc-marvell kmod-thermal-armada
+endef
+
+define Profile/XP-DB/Description
+ Package set compatible with the Marvell Armada XP evaluation board (DB-78460-BP).
+endef
+
+$(eval $(call Profile,XP-DB))
+
+define Profile/XP-GP
+ NAME:=Marvell Armada XP GP (DB-MV784MP-GP)
+ PACKAGES:= \
+ kmod-mmc kmod-mvsdio kmod-usb2 kmod-usb-storage \
+ kmod-of-i2c kmod-i2c-core kmod-i2c-mv64xxx \
+ kmod-ata-core kmod-ata-marvell-sata \
+ kmod-rtc-marvell kmod-thermal-armada
+endef
+
+define Profile/XP-GP/Description
+ Package set compatible with the Armada XP development board (DB-MV784MP-GP).
+endef
+
+$(eval $(call Profile,XP-GP))
diff --git a/target/linux/mvebu/profiles/plathome.mk b/target/linux/mvebu/profiles/plathome.mk
new file mode 100644
index 0000000000..fac31e6fc6
--- /dev/null
+++ b/target/linux/mvebu/profiles/plathome.mk
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/OpenBlocks-AX-3-4
+ NAME:=Plat'Home OpenBlocks AX3
+ PACKAGES:= \
+ kmod-usb2 kmod-usb-storage \
+ kmod-of-i2c kmod-i2c-core kmod-i2c-mv64xxx \
+ kmod-ata-core kmod-ata-marvell-sata \
+ kmod-rtc-marvell kmod-thermal-armada
+endef
+
+define Profile/OpenBlocks-AX-3-4/Description
+ Package set compatible with the Plat'Home OpenBlocks AX3.
+endef
+
+$(eval $(call Profile,OpenBlocks-AX-3-4))