summaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/profiles
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-10-08 10:01:30 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-10-08 10:01:30 +0000
commit8bb23cfb663f8870f431edba0dab218a746456a3 (patch)
tree65986ebcfaccf8aa84742ef9df45d56d0ecc356a /target/linux/mvebu/profiles
parentb3454610702d452f790aa40e7a40b536a73ee8ab (diff)
downloadmaster-31e0f0ae-8bb23cfb663f8870f431edba0dab218a746456a3.tar.gz
master-31e0f0ae-8bb23cfb663f8870f431edba0dab218a746456a3.tar.bz2
master-31e0f0ae-8bb23cfb663f8870f431edba0dab218a746456a3.zip
mvebu: add support for the Linksys WRT1900ACS (Shelby)
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 47164
Diffstat (limited to 'target/linux/mvebu/profiles')
-rw-r--r--target/linux/mvebu/profiles/linksys.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/mvebu/profiles/linksys.mk b/target/linux/mvebu/profiles/linksys.mk
index ed20cb0cf2..1a5b8afdaa 100644
--- a/target/linux/mvebu/profiles/linksys.mk
+++ b/target/linux/mvebu/profiles/linksys.mk
@@ -63,3 +63,23 @@ define Profile/Mamba/Description
endef
$(eval $(call Profile,Mamba))
+
+
+define Profile/Shelby
+ NAME:=Linksys WRT1900ACS (Shelby)
+ PACKAGES:= \
+ kmod-usb2 kmod-usb3 kmod-usb-storage \
+ kmod-i2c-core kmod-i2c-mv64xxx \
+ kmod-ata-core kmod-ata-mvebu-ahci \
+ kmod-rtc-armada38x kmod-thermal-armada \
+ kmod-gpio-button-hotplug kmod-hwmon-tmp421 \
+ kmod-leds-pca963x \
+ kmod-ledtrig-usbdev kmod-mwlwifi wpad-mini \
+ swconfig
+endef
+
+define Profile/Shelby/Description
+ Package set compatible with the Linksys WRT1900ACS (Shelby).
+endef
+
+$(eval $(call Profile,Shelby))