summaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/profiles
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-07-01 09:43:38 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-07-01 09:43:38 +0000
commit6fa01eab809a4d88fbc9b0262e6f7329576c33b1 (patch)
treea59c3beaeb1e59dccd7eac0619b65644d4643225 /target/linux/mvebu/profiles
parentfe1df543e1d97beab6e273ae28589f0c1dc0292b (diff)
downloadmaster-31e0f0ae-6fa01eab809a4d88fbc9b0262e6f7329576c33b1.tar.gz
master-31e0f0ae-6fa01eab809a4d88fbc9b0262e6f7329576c33b1.tar.bz2
master-31e0f0ae-6fa01eab809a4d88fbc9b0262e6f7329576c33b1.zip
adjust default profile, and add an evalboard one
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 41435
Diffstat (limited to 'target/linux/mvebu/profiles')
-rw-r--r--target/linux/mvebu/profiles/100-Generic.mk11
-rw-r--r--target/linux/mvebu/profiles/200-Evalboards.mk21
2 files changed, 28 insertions, 4 deletions
diff --git a/target/linux/mvebu/profiles/100-Generic.mk b/target/linux/mvebu/profiles/100-Generic.mk
index bf1b68e06c..a6923118d3 100644
--- a/target/linux/mvebu/profiles/100-Generic.mk
+++ b/target/linux/mvebu/profiles/100-Generic.mk
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2013 OpenWrt.org
+# Copyright (C) 2013-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,14 +8,17 @@
define Profile/Generic
NAME:=Generic (default)
PACKAGES:= \
- kmod-mmc kmod-mvsdio kmod-usb2 kmod-usb-storage \
+ kmod-usb2 kmod-usb3 kmod-usb-storage \
kmod-of-i2c kmod-i2c-core kmod-i2c-mv64xxx \
kmod-ata-core kmod-ata-marvell-sata \
- kmod-rtc-marvell kmod-thermal-armada
+ kmod-rtc-marvell kmod-thermal-armada \
+ kmod-gpio-button-hotplug kmod-hwmon-tmp421 \
+ kmod-hwmon-gpiofan kmod-leds-tlc59116 \
+ kmod-ledtrig-usbdev
endef
define Profile/Generic/Description
- Package set compatible with most Marvell Armada 370/XP based boards.
+ Package set compatible with most supported Marvell Armada 370/XP based boards.
endef
$(eval $(call Profile,Generic))
diff --git a/target/linux/mvebu/profiles/200-Evalboards.mk b/target/linux/mvebu/profiles/200-Evalboards.mk
new file mode 100644
index 0000000000..52d0b9803d
--- /dev/null
+++ b/target/linux/mvebu/profiles/200-Evalboards.mk
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2013-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Evalboards
+ NAME:=Evaluation / Development boards
+ PACKAGES:= \
+ kmod-mmc kmod-mvsdio kmod-usb2 kmod-usb-storage \
+ kmod-of-i2c kmod-i2c-core kmod-i2c-mv64xxx \
+ kmod-ata-core kmod-ata-marvell-sata \
+ kmod-rtc-marvell kmod-thermal-armada
+endef
+
+define Profile/Evalboards/Description
+ Package set compatible with most Marvell Armada 370/XP development based boards.
+endef
+
+$(eval $(call Profile,Evalboards))