summaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/profiles
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-07-20 10:04:03 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-21 13:29:04 +0200
commit32727c409e6deb0f90155e8427fb1ca56bc9fab2 (patch)
tree00601a7bf7e1b9eded5344bac6e078ec49aa7e4b /target/linux/mvebu/profiles
parent60d26202537d95aeda2d9903ab8668ce9cc7326b (diff)
downloadmaster-31e0f0ae-32727c409e6deb0f90155e8427fb1ca56bc9fab2.tar.gz
master-31e0f0ae-32727c409e6deb0f90155e8427fb1ca56bc9fab2.tar.bz2
master-31e0f0ae-32727c409e6deb0f90155e8427fb1ca56bc9fab2.zip
mvebu: switch to the new image build code
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/mvebu/profiles')
-rw-r--r--target/linux/mvebu/profiles/globalscale.mk17
-rw-r--r--target/linux/mvebu/profiles/linksys.mk53
-rw-r--r--target/linux/mvebu/profiles/marvell.mk72
-rw-r--r--target/linux/mvebu/profiles/plathome.mk17
-rw-r--r--target/linux/mvebu/profiles/solidrun.mk17
5 files changed, 0 insertions, 176 deletions
diff --git a/target/linux/mvebu/profiles/globalscale.mk b/target/linux/mvebu/profiles/globalscale.mk
deleted file mode 100644
index 1b9f780e79..0000000000
--- a/target/linux/mvebu/profiles/globalscale.mk
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Mirabox
- NAME:=Globalscale Mirabox
- PACKAGES:=
-endef
-
-define Profile/Mirabox/Description
- Package set compatible with the Globalscale Mirabox.
-endef
-
-$(eval $(call Profile,Mirabox))
diff --git a/target/linux/mvebu/profiles/linksys.mk b/target/linux/mvebu/profiles/linksys.mk
deleted file mode 100644
index 41f9c7d5bb..0000000000
--- a/target/linux/mvebu/profiles/linksys.mk
+++ /dev/null
@@ -1,53 +0,0 @@
-#
-# Copyright (C) 2013-2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Caiman
- NAME:=Linksys WRT1200AC (Caiman)
- PACKAGES:= kmod-mwlwifi wpad-mini swconfig
-endef
-
-define Profile/Caiman/Description
- Package set compatible with the Linksys WRT1200AC (Caiman).
-endef
-
-$(eval $(call Profile,Caiman))
-
-
-define Profile/Cobra
- NAME:=Linksys WRT1900ACv2 (Cobra)
- PACKAGES:= kmod-mwlwifi wpad-mini swconfig
-endef
-
-define Profile/Cobra/Description
- Package set compatible with the Linksys WRT1900AC (Cobra).
-endef
-
-$(eval $(call Profile,Cobra))
-
-
-define Profile/Mamba
- NAME:=Linksys WRT1900AC (Mamba)
- PACKAGES:= kmod-mwlwifi wpad-mini swconfig
-endef
-
-define Profile/Mamba/Description
- Package set compatible with the Linksys WRT1900AC (Mamba).
-endef
-
-$(eval $(call Profile,Mamba))
-
-
-define Profile/Shelby
- NAME:=Linksys WRT1900ACS (Shelby)
- PACKAGES:= kmod-mwlwifi wpad-mini swconfig
-endef
-
-define Profile/Shelby/Description
- Package set compatible with the Linksys WRT1900ACS (Shelby).
-endef
-
-$(eval $(call Profile,Shelby))
diff --git a/target/linux/mvebu/profiles/marvell.mk b/target/linux/mvebu/profiles/marvell.mk
deleted file mode 100644
index d4a1701c13..0000000000
--- a/target/linux/mvebu/profiles/marvell.mk
+++ /dev/null
@@ -1,72 +0,0 @@
-#
-# Copyright (C) 2013-2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/370-DB
- NAME:=Marvell Armada 370 DB (DB-88F6710-BP-DDR3)
- PACKAGES:=
-endef
-
-define Profile/370-DB/Description
- Package set compatible with the Armada 370 evaluation board (DB-88F6710-BP-DDR3).
-endef
-
-$(eval $(call Profile,370-DB))
-
-define Profile/370-RD
- NAME:=Marvell Armada 370 RD (RD-88F6710-A1)
- PACKAGES:=
-endef
-
-define Profile/370-RD/Description
- Package set compatible with the Armada 370 reference design board (RD-88F6710-A1).
-endef
-
-$(eval $(call Profile,370-RD))
-
-define Profile/385-RD
- NAME:=Marvell Armada 385 RD (RD-88F6820-AP)
- PACKAGES:=
-endef
-
-define Profile/385-RD/Description
- Package set compatible with the Armada 385 reference design board (RD-88F6820-AP).
-endef
-
-$(eval $(call Profile,385-RD))
-
-define Profile/385-DB-AP
- NAME:=Marvell Armada 385 DB AP (DB-88F6820-AP)
- PACKAGES:=
-endef
-
-define Profile/385-DB-AP/Description
- Package set compatible with the Armada 385 access point development board (DB-88F6820-AP).
-endef
-
-$(eval $(call Profile,385-DB-AP))
-
-define Profile/XP-DB
- NAME:=Marvell Armada XP DB (DB-78460-BP)
- PACKAGES:=
-endef
-
-define Profile/XP-DB/Description
- Package set compatible with the Marvell Armada XP evaluation board (DB-78460-BP).
-endef
-
-$(eval $(call Profile,XP-DB))
-
-define Profile/XP-GP
- NAME:=Marvell Armada XP GP (DB-MV784MP-GP)
- PACKAGES:=
-endef
-
-define Profile/XP-GP/Description
- Package set compatible with the Armada XP development board (DB-MV784MP-GP).
-endef
-
-$(eval $(call Profile,XP-GP))
diff --git a/target/linux/mvebu/profiles/plathome.mk b/target/linux/mvebu/profiles/plathome.mk
deleted file mode 100644
index 02503a190a..0000000000
--- a/target/linux/mvebu/profiles/plathome.mk
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/OpenBlocks-AX-3-4
- NAME:=Plat'Home OpenBlocks AX3
- PACKAGES:=
-endef
-
-define Profile/OpenBlocks-AX-3-4/Description
- Package set compatible with the Plat'Home OpenBlocks AX3.
-endef
-
-$(eval $(call Profile,OpenBlocks-AX-3-4))
diff --git a/target/linux/mvebu/profiles/solidrun.mk b/target/linux/mvebu/profiles/solidrun.mk
deleted file mode 100644
index e66d2cbc7d..0000000000
--- a/target/linux/mvebu/profiles/solidrun.mk
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2016 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Solidrun-Clearfog-A1
- NAME:=SolidRun ClearFog A1 board
- PACKAGES:=
-endef
-
-define Profile/Solidrun-Clearfog-A1/Description
- Package set compatible with the SolidRun ClearFog A1 board
-endef
-
-$(eval $(call Profile,Solidrun-Clearfog-A1))