summaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/profiles
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-04-16 09:54:39 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-04-16 09:54:39 +0000
commit2705cda81389e84687fb0325d2bf6c8bc2756bee (patch)
tree43e62f4855251c4117b245bccebe1fb75534fa9e /target/linux/mvebu/profiles
parent0926e4c22feb8b9f65d7fbf9deb880de031fd0a2 (diff)
downloadmaster-31e0f0ae-2705cda81389e84687fb0325d2bf6c8bc2756bee.tar.gz
master-31e0f0ae-2705cda81389e84687fb0325d2bf6c8bc2756bee.tar.bz2
master-31e0f0ae-2705cda81389e84687fb0325d2bf6c8bc2756bee.zip
mvebu: add support for the Linksys Caiman and Cobra
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 45456
Diffstat (limited to 'target/linux/mvebu/profiles')
-rw-r--r--target/linux/mvebu/profiles/linksys.mk40
1 files changed, 40 insertions, 0 deletions
diff --git a/target/linux/mvebu/profiles/linksys.mk b/target/linux/mvebu/profiles/linksys.mk
index 1bacb971d9..ed20cb0cf2 100644
--- a/target/linux/mvebu/profiles/linksys.mk
+++ b/target/linux/mvebu/profiles/linksys.mk
@@ -5,6 +5,46 @@
# See /LICENSE for more information.
#
+define Profile/Caiman
+ NAME:=Linksys WRT1200AC (Caiman)
+ PACKAGES:= \
+ kmod-usb2 kmod-usb3 kmod-usb-storage \
+ kmod-i2c-core kmod-i2c-mv64xxx \
+ kmod-ata-core kmod-ata-mvebu-ahci \
+ kmod-rtc-armada38x kmod-thermal-armada \
+ kmod-gpio-button-hotplug kmod-hwmon-tmp421 \
+ kmod-leds-pca963x \
+ kmod-ledtrig-usbdev kmod-mwlwifi wpad-mini \
+ swconfig
+endef
+
+define Profile/Caiman/Description
+ Package set compatible with the Linksys WRT1200AC (Caiman).
+endef
+
+$(eval $(call Profile,Caiman))
+
+
+define Profile/Cobra
+ NAME:=Linksys WRT1900ACv2 (Cobra)
+ PACKAGES:= \
+ kmod-usb2 kmod-usb3 kmod-usb-storage \
+ kmod-i2c-core kmod-i2c-mv64xxx \
+ kmod-ata-core kmod-ata-mvebu-ahci \
+ kmod-rtc-armada38x kmod-thermal-armada \
+ kmod-gpio-button-hotplug kmod-hwmon-tmp421 \
+ kmod-leds-pca963x \
+ kmod-ledtrig-usbdev kmod-mwlwifi wpad-mini \
+ swconfig
+endef
+
+define Profile/Cobra/Description
+ Package set compatible with the Linksys WRT1900AC (Cobra).
+endef
+
+$(eval $(call Profile,Cobra))
+
+
define Profile/Mamba
NAME:=Linksys WRT1900AC (Mamba)
PACKAGES:= \