summaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/profiles
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-01-17 22:28:33 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-01-17 22:28:33 +0000
commit15b4681e3e9732ef2d414a1599b14959ccea5746 (patch)
tree1754f2d31b3bcc6b6a65c6111b3576e4ada2afef /target/linux/mvebu/profiles
parentf517d0481a92aa0465d0a677302c2119bda888ec (diff)
downloadmaster-31e0f0ae-15b4681e3e9732ef2d414a1599b14959ccea5746.tar.gz
master-31e0f0ae-15b4681e3e9732ef2d414a1599b14959ccea5746.tar.bz2
master-31e0f0ae-15b4681e3e9732ef2d414a1599b14959ccea5746.zip
mvebu: add default profile
Such that relevant kernel modules are selected (USB, I2C, SATA, RTC, SDIO) Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 35206
Diffstat (limited to 'target/linux/mvebu/profiles')
-rw-r--r--target/linux/mvebu/profiles/100-Generic.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/mvebu/profiles/100-Generic.mk b/target/linux/mvebu/profiles/100-Generic.mk
new file mode 100644
index 0000000000..3520cc42ce
--- /dev/null
+++ b/target/linux/mvebu/profiles/100-Generic.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+ NAME:=Generic (default)
+ PACKAGES:=kmod-mmc kmod-mvsdio kmod-usb2 kmod-usb-storage \
+ kmod-of-i2c kmod-i2c-core kmod-i2c-mv64xxx \
+ kmod-ata-core kmod-ata-marvell-sata \
+ kmod-rtc-marvell
+endef
+
+define Profile/Generic/Description
+ Package set compatible with most Marvell Armada 370/XP based boards
+endef
+$(eval $(call Profile,Generic))
+