summaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/profiles/marvell.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-05-21 19:09:59 +0200
committerFelix Fietkau <nbd@nbd.name>2016-05-21 19:57:06 +0200
commitf849c2c83247340d623fdb549e2b75f4c1feea62 (patch)
tree2d55138ecd6dd651e2343c1642e80c29522255b4 /target/linux/mvebu/profiles/marvell.mk
parenta5a3b59bf54c72c1eea7745d7a83dfc298d4ae1e (diff)
downloadmaster-31e0f0ae-f849c2c83247340d623fdb549e2b75f4c1feea62.tar.gz
master-31e0f0ae-f849c2c83247340d623fdb549e2b75f4c1feea62.tar.bz2
master-31e0f0ae-f849c2c83247340d623fdb549e2b75f4c1feea62.zip
mvebu: enable core drivers in the kernel config instead of packaging them
Simplify profile package selection Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/mvebu/profiles/marvell.mk')
-rw-r--r--target/linux/mvebu/profiles/marvell.mk35
1 files changed, 6 insertions, 29 deletions
diff --git a/target/linux/mvebu/profiles/marvell.mk b/target/linux/mvebu/profiles/marvell.mk
index e8ca9bd250..d4a1701c13 100644
--- a/target/linux/mvebu/profiles/marvell.mk
+++ b/target/linux/mvebu/profiles/marvell.mk
@@ -7,11 +7,7 @@
define Profile/370-DB
NAME:=Marvell Armada 370 DB (DB-88F6710-BP-DDR3)
- PACKAGES:= \
- kmod-mmc kmod-mvsdio kmod-usb2 kmod-usb-storage \
- kmod-i2c-core kmod-i2c-mv64xxx \
- kmod-ata-core kmod-ata-marvell-sata \
- kmod-rtc-marvell kmod-thermal-armada
+ PACKAGES:=
endef
define Profile/370-DB/Description
@@ -22,11 +18,7 @@ $(eval $(call Profile,370-DB))
define Profile/370-RD
NAME:=Marvell Armada 370 RD (RD-88F6710-A1)
- PACKAGES:= \
- kmod-mmc kmod-mvsdio kmod-usb2 kmod-usb-storage \
- kmod-i2c-core kmod-i2c-mv64xxx \
- kmod-ata-core kmod-ata-marvell-sata \
- kmod-rtc-marvell kmod-thermal-armada
+ PACKAGES:=
endef
define Profile/370-RD/Description
@@ -37,10 +29,7 @@ $(eval $(call Profile,370-RD))
define Profile/385-RD
NAME:=Marvell Armada 385 RD (RD-88F6820-AP)
- PACKAGES:= \
- kmod-mmc kmod-mvsdio kmod-usb3 kmod-usb-storage \
- kmod-i2c-core kmod-i2c-mv64xxx \
- kmod-thermal-armada
+ PACKAGES:=
endef
define Profile/385-RD/Description
@@ -51,11 +40,7 @@ $(eval $(call Profile,385-RD))
define Profile/385-DB-AP
NAME:=Marvell Armada 385 DB AP (DB-88F6820-AP)
- PACKAGES:= \
- kmod-usb3 kmod-usb-storage \
- kmod-i2c-core kmod-i2c-mv64xxx \
- kmod-ata-core kmod-ata-marvell-sata \
- kmod-thermal-armada
+ PACKAGES:=
endef
define Profile/385-DB-AP/Description
@@ -66,11 +51,7 @@ $(eval $(call Profile,385-DB-AP))
define Profile/XP-DB
NAME:=Marvell Armada XP DB (DB-78460-BP)
- PACKAGES:= \
- kmod-mmc kmod-mvsdio kmod-usb2 kmod-usb-storage \
- kmod-i2c-core kmod-i2c-mv64xxx \
- kmod-ata-core kmod-ata-marvell-sata \
- kmod-rtc-marvell kmod-thermal-armada
+ PACKAGES:=
endef
define Profile/XP-DB/Description
@@ -81,11 +62,7 @@ $(eval $(call Profile,XP-DB))
define Profile/XP-GP
NAME:=Marvell Armada XP GP (DB-MV784MP-GP)
- PACKAGES:= \
- kmod-mmc kmod-mvsdio kmod-usb2 kmod-usb-storage \
- kmod-i2c-core kmod-i2c-mv64xxx \
- kmod-ata-core kmod-ata-marvell-sata \
- kmod-rtc-marvell kmod-thermal-armada
+ PACKAGES:=
endef
define Profile/XP-GP/Description