summaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-02-05 11:25:21 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-02-05 11:25:21 +0000
commitf14c4e5cff218b6c333d9c61e0b0cdff547f4781 (patch)
treed727002d60beffd340756c7dfeea6f0fc943fb23 /target/linux/mvebu/image
parente46593a54cb8e06a5aefd909b0984ccc30a525c1 (diff)
downloadmaster-31e0f0ae-f14c4e5cff218b6c333d9c61e0b0cdff547f4781.tar.gz
master-31e0f0ae-f14c4e5cff218b6c333d9c61e0b0cdff547f4781.tar.bz2
master-31e0f0ae-f14c4e5cff218b6c333d9c61e0b0cdff547f4781.zip
mvebu: add a subprofile for boards based on a small NOR
Some boards only come with a small NOR on it, where UBI isn't a good solution because of its overhead. Add a new subprofile for such boards, that rely on the mtd split framework instead. Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com> Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 44263
Diffstat (limited to 'target/linux/mvebu/image')
-rw-r--r--target/linux/mvebu/image/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 7076e876e0..a8fc4de134 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -77,6 +77,31 @@ define UBINORProfile
endef
# $(1): Profile Name
+# $(2): DTB Name
+# $(3): Erase Block Size
+define NORProfile
+ define Image/BuildKernel/Profile/$(1)
+ $(call Image/Build/DTB,$(2))
+ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
+ $(call Image/Build/Profile,$(1)/Initramfs)
+ endif
+ endef
+
+ define Image/Build/Profile/$(1)/Initramfs
+ $(call Image/Build/DTB,$(2),-initramfs)
+ endef
+
+ define Image/Build/Profile/$(1)/squashfs
+ ( \
+ dd if=$(KDIR)/uImage-$(2) bs=$(3) conv=sync; \
+ dd if=$(KDIR)/root.squashfs bs=$(3) conv=sync; \
+ ) > $$(BIN_DIR)/$$(IMG_PREFIX)-$(2)-squashfs-firmware.bin
+ endef
+
+ PROFILES_LIST += $(1)
+endef
+
+# $(1): Profile Name
# $(2): Sub Profiles list
define MultiProfile
define Image/BuildKernel/Profile/$(1)