summaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-02-05 11:24:10 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-02-05 11:24:10 +0000
commite46593a54cb8e06a5aefd909b0984ccc30a525c1 (patch)
treef06701b1f9f8da562d5f5206e8f4d9c8e57a61bb /target/linux/mvebu/image
parent80cfe3429174cf4cb9408f2d690c66051c2ee4be (diff)
downloadmaster-31e0f0ae-e46593a54cb8e06a5aefd909b0984ccc30a525c1.tar.gz
master-31e0f0ae-e46593a54cb8e06a5aefd909b0984ccc30a525c1.tar.bz2
master-31e0f0ae-e46593a54cb8e06a5aefd909b0984ccc30a525c1.zip
mvebu: add large NOR sub-profile implementation
While we supported only the NAND so far, some boards use a large enough NOR, where UBI is the only reasonable option. Create a new sub-profile template with a different set of UBI options. Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com> Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 44262
Diffstat (limited to 'target/linux/mvebu/image')
-rw-r--r--target/linux/mvebu/image/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 0b69d4b38f..7076e876e0 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -55,6 +55,28 @@ define NANDProfile
endef
# $(1): Profile Name
+# $(2): DTB Name
+# $(3): Erase Block Size
+define UBINORProfile
+ define Image/BuildKernel/Profile/$(1)
+ $(call Image/Build/DTB,$(2))
+ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
+ $(call Image/Build/Profile,$(1)/Initramfs)
+ endif
+ endef
+
+ define Image/Build/Profile/$(1)/Initramfs
+ $(call Image/Build/DTB,$(2),-initramfs)
+ endef
+
+ define Image/Build/Profile/$(1)/squashfs
+ $(call Image/Build/UbinizeImage,$(2),,squashfs, -p $(3) -m 1)
+ endef
+
+ PROFILES_LIST += $(1)
+endef
+
+# $(1): Profile Name
# $(2): Sub Profiles list
define MultiProfile
define Image/BuildKernel/Profile/$(1)