summaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-04-13 12:08:42 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-04-13 12:08:42 +0000
commite3bd4f09692c2ecb0a611fecf050be9693c667c0 (patch)
tree44e35fc43ef577bc528fb23d97758d52e0e8cd62 /target/linux/mvebu/image
parent96c793f529105a80953a586568efbe0142ea7625 (diff)
downloadmaster-31e0f0ae-e3bd4f09692c2ecb0a611fecf050be9693c667c0.tar.gz
master-31e0f0ae-e3bd4f09692c2ecb0a611fecf050be9693c667c0.tar.bz2
master-31e0f0ae-e3bd4f09692c2ecb0a611fecf050be9693c667c0.zip
mvebu: stop legacy image generation
If you can't find the firmware for you board, send proper patches. Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 45413
Diffstat (limited to 'target/linux/mvebu/image')
-rw-r--r--target/linux/mvebu/image/Makefile6
1 files changed, 0 insertions, 6 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 191dc27a00..269ad19991 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -22,8 +22,6 @@ define Image/Build/DTB
$(call Image/BuildKernel/MkuImage, \
none, $(LOADADDR), $(LOADADDR), \
$(KDIR)/zImage$(2)-$(1), $(KDIR)/uImage$(2)-$(1))
-# The next line will be dropped, migrate your board to use a single firmware file
- cp $(KDIR)/uImage$(2)-$(1) $(UIMAGE)$(2)-$(1);
endef
# $(1): Profile Name
@@ -50,8 +48,6 @@ define NANDProfile
define Image/Build/Profile/$(1)/squashfs
$(call Image/Build/UbinizeImage,$(2),,squashfs, -p $(3) -m $(4) $(if $(5),-s $(5)) $(if $(6),-O $(6)))
-# The next line will be dropped, migrate your board to use a single firmware file
- cp $(KDIR)/$$(IMG_PREFIX)-$(2)-squashfs-ubinized.bin $(BIN_DIR)
endef
PROFILES_LIST += $(1)
@@ -179,8 +175,6 @@ endef
define Image/Build
$(call Image/Build/$(1))
-# The next line will be dropped, migrate your board to use a single firmware file
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
$(call Image/Build/Profile/$(PROFILE)/BuildSysupgrade,$(1))
ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
$(call Image/Build/Profile/$(PROFILE)/Initramfs)