summaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-12-26 13:45:18 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-12-26 13:45:18 +0000
commite23b988bf5ac41db6e78517900413b1117804728 (patch)
treee2180c0429ea98e3b822d6c6df331401ffdf5fd6 /target/linux/mvebu/image
parentf3755f57584bf1b0273c527964a0ea8ac43fd13d (diff)
downloadmaster-31e0f0ae-e23b988bf5ac41db6e78517900413b1117804728.tar.gz
master-31e0f0ae-e23b988bf5ac41db6e78517900413b1117804728.tar.bz2
master-31e0f0ae-e23b988bf5ac41db6e78517900413b1117804728.zip
only call UbinizeImage and BuildSysUpgrade for boards we support them on
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 43779
Diffstat (limited to 'target/linux/mvebu/image')
-rw-r--r--target/linux/mvebu/image/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index c2dcd8cd06..92571e2153 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -10,6 +10,8 @@ include $(INCLUDE_DIR)/image.mk
TARGET_DTBS := armada-xp-db armada-370-db armada-xp-openblocks-ax3-4 armada-370-mirabox \
armada-370-rd armada-xp-gp armada-xp-mamba
+NANDBOARDS := armada-xp-mamba
+
LOADADDR:=0x00008000
JFFS2_BLOCKSIZE = 128k
@@ -43,7 +45,7 @@ endef
define Image/Build/squashfs
$(STAGING_DIR_HOST)/bin/padjffs2 $(KDIR)/root.squashfs 128
- $(foreach dtb,$(TARGET_DTBS),$(call Image/Build/UbinizeImage,$(dtb),,squashfs,$(UBI_OPTS));)
+ $(foreach nandboard,$(NANDBOARDS),$(call Image/Build/UbinizeImage,$(nandboard),,squashfs,$(UBI_OPTS));)
( \
dd if=$(KDIR)/uImage-armada-xp-mamba bs=3072k conv=sync; \
dd if=$(KDIR)/$(IMG_PREFIX)-armada-xp-mamba-squashfs-ubinized.bin \
@@ -62,7 +64,7 @@ endef
define Image/Build
$(call Image/Build/$(1))
dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
- $(foreach dtb,$(TARGET_DTBS),$(call BuildSysupgrade,$(1),$(dtb));)
+ $(foreach nandboard,$(NANDBOARDS),$(call BuildSysupgrade,$(1),$(nandboard));)
ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
$(call Image/Build/Initramfs)
endif