summaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-04-13 12:15:40 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-04-13 12:15:40 +0000
commitc9e6c7c8364572eac35206627aac4b9d2e551d62 (patch)
treeeae37f30c5a6ee60148265fc52217b81baf5ee1b /target/linux/mvebu/image
parente3bd4f09692c2ecb0a611fecf050be9693c667c0 (diff)
downloadmaster-31e0f0ae-c9e6c7c8364572eac35206627aac4b9d2e551d62.tar.gz
master-31e0f0ae-c9e6c7c8364572eac35206627aac4b9d2e551d62.tar.bz2
master-31e0f0ae-c9e6c7c8364572eac35206627aac4b9d2e551d62.zip
mvebu: add comments to image generation
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 45414
Diffstat (limited to 'target/linux/mvebu/image')
-rw-r--r--target/linux/mvebu/image/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 269ad19991..0d75e30eda 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -141,6 +141,11 @@ $(eval $(call UBINORProfile,OpenBlocks-AX-3-4,armada-xp-openblocks-ax3-4,128KiB)
# Boards with small NOR, where UBI doesn't make sense
$(eval $(call NORProfile,385-RD,armada-385-rd,256KiB))
+###
+### Linksys
+###
+
+# Mamba: Linksys WRT1900AC
define Image/Build/Profile/Mamba/squashfs
$(call Image/Build/UbinizeImage,armada-xp-linksys-mamba,,squashfs, -p 128KiB -m 2048 -s 512 -O 2048)
( \
@@ -150,6 +155,11 @@ define Image/Build/Profile/Mamba/squashfs
) > $(BIN_DIR)/$(IMG_PREFIX)-armada-xp-linksys-mamba-squashfs-factory.img
endef
+###
+### Marvell
+###
+
+# Marvell Armada 385 Access Point Development board (DB-88F6820-AP)
define Image/Build/Profile/385-DB-AP/squashfs
$(call Image/Build/UbinizeImage,armada-385-db-ap,,squashfs, -p 256KiB -m 4096)
( \
@@ -159,6 +169,7 @@ define Image/Build/Profile/385-DB-AP/squashfs
) > $(BIN_DIR)/$(IMG_PREFIX)-armada-385-db-ap-squashfs-factory.img
endef
+
# The Default profile should build everything
$(eval $(call MultiProfile,Default,$(PROFILES_LIST)))