summaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-02-05 11:22:43 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-02-05 11:22:43 +0000
commit80cfe3429174cf4cb9408f2d690c66051c2ee4be (patch)
tree7a41fe74bec710554a6658a5e2a8d30e2796ca9d /target/linux/mvebu/image
parentb361a9d59a725b50f00f47ccf319cf86ba5f43c4 (diff)
downloadmaster-31e0f0ae-80cfe3429174cf4cb9408f2d690c66051c2ee4be.tar.gz
master-31e0f0ae-80cfe3429174cf4cb9408f2d690c66051c2ee4be.tar.bz2
master-31e0f0ae-80cfe3429174cf4cb9408f2d690c66051c2ee4be.zip
mvebu: Add sub-profiles
In order to support the various board NAND layout that we support, introduce a sub-profile similar to the one used by ar71xx. These subprofiles provide a default implementation for most of the building functions, while allowing each sub-profile to override any of these operations in order to have a more specific behaviour, like Mamba expects for example. Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com> Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 44261
Diffstat (limited to 'target/linux/mvebu/image')
-rw-r--r--target/linux/mvebu/image/Makefile96
1 files changed, 74 insertions, 22 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 6e00346fe2..0b69d4b38f 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -7,18 +7,10 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-TARGET_DTBS := armada-xp-db armada-370-db armada-xp-openblocks-ax3-4 armada-370-mirabox \
- armada-370-rd armada-xp-gp armada-xp-mamba
-
-NANDBOARDS := armada-xp-mamba
-
LOADADDR:=0x00008000
JFFS2_BLOCKSIZE = 128k
-UBIFS_OPTS = -F -m 2048 -e 124KiB -c 4096 -U
-UBI_OPTS = -m 2048 -p 128KiB -s 512 -O 2048
-
KDIR_TMP:=$(KDIR)/tmp
@@ -33,16 +25,70 @@ define Image/Build/DTB
cp $(KDIR)/uImage$(2)-$(1) $(UIMAGE)$(2)-$(1);
endef
-define Image/BuildKernel
- $(foreach dtb,$(TARGET_DTBS),$(call Image/Build/DTB,$(dtb)))
- ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
- $(call Image/Build/Initramfs)
- endif
+# $(1): Profile Name
+# $(2): DTB Name
+# $(3): Erase Block Size
+# $(4): Page Size
+# $(5): Sub-Page Size (optional)
+define NANDProfile
+ define Image/BuildKernel/Profile/$(1)
+ $(call Image/Build/DTB,$(2))
+ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
+ $(call Image/Build/Profile,$(1)/Initramfs)
+ endif
+ endef
+
+ define Image/Build/Profile/$(1)/BuildSysupgrade
+ $(call Image/Build/SysupgradeNAND,$(2),$$(1),$(KDIR)/uImage-$(2))
+ endef
+
+ define Image/Build/Profile/$(1)/Initramfs
+ $(call Image/Build/DTB,$(2),-initramfs)
+ endef
+
+ define Image/Build/Profile/$(1)/squashfs
+ $(call Image/Build/UbinizeImage,$(2),,squashfs, -p $(3) -m $(4) $(if $(5),-s $(5)))
+ cp $(KDIR)/$$(IMG_PREFIX)-$(2)-squashfs-ubinized.bin $(BIN_DIR)
+ endef
+
+ PROFILES_LIST += $(1)
endef
-define Image/Build/squashfs
- $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
- $(foreach nandboard,$(NANDBOARDS),$(call Image/Build/UbinizeImage,$(nandboard),,squashfs,$(UBI_OPTS));)
+# $(1): Profile Name
+# $(2): Sub Profiles list
+define MultiProfile
+ define Image/BuildKernel/Profile/$(1)
+ $(foreach profile, $(2),
+ $(call Image/BuildKernel/Profile/$(profile)))
+ endef
+
+ define Image/Build/Profile/$(1)/BuildSysupgrade
+ $(foreach profile, $(2),
+ $(call Image/Build/Profile/$(profile)/BuildSysupgrade,$$(1)))
+ endef
+
+ define Image/Build/Profile/$(1)/Initramfs
+ $(foreach profile, $(2),
+ $(call Image/Build/Profile/$(profile)/Initramfs))
+ endef
+
+ define Image/Build/Profile/$(1)/squashfs
+ $(foreach profile, $(2),
+ $(call Image/Build/Profile/$(profile)/squashfs))
+ endef
+endef
+
+# Boards with NAND, with subpages
+$(eval $(call NANDProfile,370-DB,armada-370-db,128KiB,2048,512))
+$(eval $(call NANDProfile,370-RD,armada-370-rd,128KiB,2048,512))
+$(eval $(call NANDProfile,Mamba,armada-xp-mamba,128KiB,2048,512))
+$(eval $(call NANDProfile,Mirabox,armada-370-mirabox,128KiB,2048,512))
+$(eval $(call NANDProfile,OpenBlocks-AX-3-4,armada-xp-openblocks-ax3-4,128KiB,2048,512))
+$(eval $(call NANDProfile,XP-DB,armada-xp-db,128KiB,2048,512))
+$(eval $(call NANDProfile,XP-GP,armada-xp-gp,128KiB,2048,512))
+
+define Image/Build/Profile/Mamba/squashfs
+ $(call Image/Build/UbinizeImage,armada-xp-mamba,,squashfs, -p 128KiB -m 2048 -s 512)
( \
dd if=$(KDIR)/uImage-armada-xp-mamba bs=3072k conv=sync; \
dd if=$(KDIR)/$(IMG_PREFIX)-armada-xp-mamba-squashfs-ubinized.bin \
@@ -50,20 +96,26 @@ define Image/Build/squashfs
) > $(BIN_DIR)/$(IMG_PREFIX)-armada-xp-mamba-squashfs-factory.img
endef
-define Image/Build/Initramfs
- $(foreach dtb,$(TARGET_DTBS),$(call Image/Build/DTB,$(dtb),-initramfs))
+$(eval $(call MultiProfile,Generic,$(PROFILES_LIST)))
+$(eval $(call MultiProfile,Evalboards,$(PROFILES_LIST)))
+
+define Image/BuildKernel
+ $(call Image/BuildKernel/Profile/$(PROFILE))
endef
-define BuildSysupgrade
- $(call Image/Build/SysupgradeNAND,$(2),$(1),$(KDIR)/uImage-$(2))
+define Image/Build/squashfs
+ # Align the squashfs image size before calling the profiles,
+ # otherwise the size would keep growing
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+ $(call Image/Build/Profile/$(PROFILE)/squashfs)
endef
define Image/Build
$(call Image/Build/$(1))
dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
- $(foreach nandboard,$(NANDBOARDS),$(call BuildSysupgrade,$(1),$(nandboard));)
+ $(call Image/Build/Profile/$(PROFILE)/BuildSysupgrade,$(1))
ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
- $(call Image/Build/Initramfs)
+ $(call Image/Build/Profile/$(PROFILE)/Initramfs)
endif
endef