summaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2016-02-17 17:49:26 +0000
committerLuka Perkov <luka@openwrt.org>2016-02-17 17:49:26 +0000
commit4d966e4dde31aaa93023a643a128ea764b6d583b (patch)
tree8d3cef91f9698f10c635730274cab3acdb0f18a2 /target/linux/mvebu/image
parent5445a2ee1d0ec8a42e16a68d03c69375da31ee82 (diff)
downloadmaster-31e0f0ae-4d966e4dde31aaa93023a643a128ea764b6d583b.tar.gz
master-31e0f0ae-4d966e4dde31aaa93023a643a128ea764b6d583b.tar.bz2
master-31e0f0ae-4d966e4dde31aaa93023a643a128ea764b6d583b.zip
mvebu: add SolidRun ClearFog A1 support
Signed-off-by: Andrej Vlasic <andrej.vlasic@sartura.hr> SVN-Revision: 48736
Diffstat (limited to 'target/linux/mvebu/image')
-rw-r--r--target/linux/mvebu/image/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 123be9eac2..cb73c3bea6 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -98,6 +98,26 @@ define NORProfile
endef
# $(1): Profile Name
+# $(2): DTB Name
+define MMCProfile
+ define Image/BuildKernel/Profile/$(1)
+ $(call Image/Build/DTB,$(2))
+ cp $(KDIR)/zImage-$(2) $(BIN_DIR)/zImage-$(1);
+ cp $(DTS_DIR)/$(2).dtb $(BIN_DIR)/$(1).dtb;
+ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
+ $(call Image/Build/Profile,$(1)/Initramfs)
+ endif
+ endef
+
+ define Image/Build/Profile/$(1)/Initramfs
+ $(call Image/Build/DTB,$(2),-initramfs)
+ cp $(KDIR)/uImage-initramfs-$(2) $(BIN_DIR)/$(IMG_PREFIX)-$(2)-initramfs
+ endef
+
+ PROFILES_LIST += $(1)
+endef
+
+# $(1): Profile Name
# $(2): Sub Profiles list
define MultiProfile
define Image/BuildKernel/Profile/$(1)
@@ -141,6 +161,8 @@ $(eval $(call UBINORProfile,OpenBlocks-AX-3-4,armada-xp-openblocks-ax3-4,128KiB)
# Boards with small NOR, where UBI doesn't make sense
$(eval $(call NORProfile,388-RD,armada-388-rd,256KiB))
+$(eval $(call MMCProfile,Solidrun-Clearfog-A1,armada-388-clearfog))
+
###
### Linksys
###