summaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-02-05 11:26:17 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-02-05 11:26:17 +0000
commit40daf9346edeec0f21330bd6be1e89b15f85c5e6 (patch)
treee5b9ac489f681b18896be911f0047d2ac48887b6 /target/linux/mvebu/image
parentf14c4e5cff218b6c333d9c61e0b0cdff547f4781 (diff)
downloadmaster-31e0f0ae-40daf9346edeec0f21330bd6be1e89b15f85c5e6.tar.gz
master-31e0f0ae-40daf9346edeec0f21330bd6be1e89b15f85c5e6.tar.bz2
master-31e0f0ae-40daf9346edeec0f21330bd6be1e89b15f85c5e6.zip
mvebu: fix NAND and NOR options
All the boards but Mamba had wrong UBI options so far, making it impossible to flash the built image on their respective storage medium. Fix all of the supported boards in order to make the generated images useful. Tested on a Mirabox, an Armada XP GP and an Openblocks AX3, and used the NAND chip datasheet for the others. Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com> Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 44264
Diffstat (limited to 'target/linux/mvebu/image')
-rw-r--r--target/linux/mvebu/image/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index a8fc4de134..c8ec72e87c 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -125,14 +125,18 @@ define MultiProfile
endef
endef
+# Boards with NAND, without subpages
+$(eval $(call NANDProfile,370-DB,armada-370-db,512KiB,4096))
+$(eval $(call NANDProfile,370-RD,armada-370-rd,512KiB,4096))
+$(eval $(call NANDProfile,Mirabox,armada-370-mirabox,512KiB,4096))
+$(eval $(call NANDProfile,XP-DB,armada-xp-db,512KiB,4096))
+$(eval $(call NANDProfile,XP-GP,armada-xp-gp,512KiB,4096))
+
# Boards with NAND, with subpages
-$(eval $(call NANDProfile,370-DB,armada-370-db,128KiB,2048,512))
-$(eval $(call NANDProfile,370-RD,armada-370-rd,128KiB,2048,512))
$(eval $(call NANDProfile,Mamba,armada-xp-mamba,128KiB,2048,512))
-$(eval $(call NANDProfile,Mirabox,armada-370-mirabox,128KiB,2048,512))
-$(eval $(call NANDProfile,OpenBlocks-AX-3-4,armada-xp-openblocks-ax3-4,128KiB,2048,512))
-$(eval $(call NANDProfile,XP-DB,armada-xp-db,128KiB,2048,512))
-$(eval $(call NANDProfile,XP-GP,armada-xp-gp,128KiB,2048,512))
+
+# Boards with large NOR, where we want to use UBI
+$(eval $(call UBINORProfile,OpenBlocks-AX-3-4,armada-xp-openblocks-ax3-4,128KiB))
define Image/Build/Profile/Mamba/squashfs
$(call Image/Build/UbinizeImage,armada-xp-mamba,,squashfs, -p 128KiB -m 2048 -s 512)