summaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-06-29 13:10:35 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-06-29 13:10:35 +0000
commit3e4932758e088541dca89ddd7204d4f880a3e40b (patch)
tree84f07b5da074ff25932c12a806c6465712e3b618 /target/linux/mvebu/image
parent0bc385d06495fbc7c6d9d0e2d71571c50b01dd8f (diff)
downloadmaster-31e0f0ae-3e4932758e088541dca89ddd7204d4f880a3e40b.tar.gz
master-31e0f0ae-3e4932758e088541dca89ddd7204d4f880a3e40b.tar.bz2
master-31e0f0ae-3e4932758e088541dca89ddd7204d4f880a3e40b.zip
build firmware images for the Mamba (Linksys WRT1900AC)
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 41387
Diffstat (limited to 'target/linux/mvebu/image')
-rw-r--r--target/linux/mvebu/image/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index fb0dc4f1f0..9de7e96086 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -44,6 +44,11 @@ endef
define Image/Build/squashfs
$(STAGING_DIR_HOST)/bin/padjffs2 $(KDIR)/root.squashfs 128
$(foreach dtb,$(TARGET_DTBS),$(call Image/Build/UbinizeImage,$(dtb),,squashfs,$(UBI_OPTS));)
+ ( \
+ dd if=$(KDIR)/uImage-armada-xp-mamba bs=3072k conv=sync; \
+ dd if=$(BIN_DIR)/$(IMG_PREFIX)-armada-xp-mamba-squashfs-ubinized.bin \
+ bs=2048 conv=sync; \
+ ) > $(BIN_DIR)/$(IMG_PREFIX)-mamba-squashfs.img
endef
define Image/Build/Initramfs